1

I've got cygwin installed on a windows machine & I'm trying to run squid. But when I run /usr/sbin/squid -i it does nothing, no response, no log files, nothing. I've tried searching for solutions but all I've found is one particularly hostile thread on the squid maling list. The doco just says to run with the -i to install as a windows service

0
4

There's no need to run Squid in Cygwin; Guido Serassio maintains binary installers for Windows, invlufi. Try using one of those instead; it has the same exact interface as the Linux versions.

2
  • I must be blind, I can't see the installers on that link.
    – barthoda
    Sep 1 '10 at 2:10
  • Link no longer works
    – Shayan
    Dec 2 '20 at 16:30
4

From this answer on superuser, I found that I first needed to run /usr/sbin/squid -z and then /usr/sbin/squid. Log files appear at /var/log/squid/ after that.

3

The references to acmeconsulting are no longer current. The commonly referenced page http://squid.acmeconsulting.it/index.html has Squid for Windows v2.7 which is sorely out of date from the current v3.1. On that page is a link for Squid for Windows v3.0. The information there is that due to issues with Bazaar, Squid for Windows is essentially a dead and outdated project. Further, there is no link for v3.x for Windows. Therefore, if you want anything more recent than 6 year old software on Windows, you need to either go for a Cygwin implementation, go virtual with a local VMware instance with *nix, or install on a low-cost cloud-based private server.

My approach: I'm looking into the Cygwin solution now. If that doesn't work, I will progress on to a manually installed VMware instance. If that doesn't work I may try a pre-installed VMWare appliance (DansGuardian?), but only if I can get a personal-use version for free. If that doesn't work, I'll accept that the internet is just slow and deal with it. ;)

Other suggestions for Squid on Windows are welcome, but please, let's start deprecating all of these references to the fine work done at acmeconsulting - it's simply not valid anymore.

HTH

2
  • Have you got it working on Cygwin?
    – Shayan
    Dec 2 '20 at 16:31
  • I am no longer using Cygwin or Squid. The notes here were posted 9 years ago. ;)
    – TonyG
    Dec 2 '20 at 20:48
2

There is a Squid MSI Installer at GitHub Squid Windows Installer. It is an open source project to ease installation of Squid on Windows. Currently it is based on Cygwin Squid 3.3.3; 3.5.1 version will be published soon.

0

Have a look at this link.
You may be interested at first in the -d option.

You could also try to re-compile squid in cygwin (in setup.exe, install the development tools).

0

Configure /etc/resolv.conf file . I found this problem with debug mode!

$ /usr/sbin/squid.exe -f squid.conf -d 5 -N
2017/02/13 17:47:56| Starting Squid Cache version 3.3.3 for x86_64-unknown-cygwin...
2017/02/13 17:47:56| Process ID 9848
2017/02/13 17:47:56| Process Roles: master worker
2017/02/13 17:47:56| With 3072 file descriptors available
2017/02/13 17:47:56| Initializing IP Cache...
2017/02/13 17:47:56| DNS Socket created at [::], FD 4
2017/02/13 17:47:56| DNS Socket created at 0.0.0.0, FD 5
2017/02/13 17:47:56| /etc/resolv.conf: (2) No such file or directory
2017/02/13 17:47:56| Warning: Could not find any nameservers. Trying to use localhost
2017/02/13 17:47:56| Please check your /etc/resolv.conf file
2017/02/13 17:47:56| or use the 'dns_nameservers' option in squid.conf.
2017/02/13 17:47:56| Logfile: opening log daemon:/var/log/squid/access.log
2017/02/13 17:47:56| Logfile Daemon: opening log /var/log/squid/access.log
2017/02/13 17:47:56| WARNING: no_suid: setuid(0): (22) Invalid argument
2017/02/13 17:47:56| Store logging disabled
2017/02/13 17:47:56| Swap maxSize 0 + 262144 KB, estimated 20164 objects
2017/02/13 17:47:56| Target number of buckets: 1008
2017/02/13 17:47:56| Using 8192 Store buckets
2017/02/13 17:47:56| Max Mem  size: 262144 KB
2017/02/13 17:47:56| Max Swap size: 0 KB
2017/02/13 17:47:56| Using Least Load store dir selection
2017/02/13 17:47:56| Set Current Directory to /var/spool/squid
2017/02/13 17:47:56| Loaded Icons.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.