4

Basically, I'm trying to make SOAP calls from a Tomcat server via a corporate proxy/ firewall (which I have no direct control over), I've tried to add info to the catalina.properties file as shown:

http.proxyPort=80
http.proxyHost=www-proxy.company.com

I'm still getting timeouts in the stdout logs. Do I need to do anything else and if not is there another way to test the SOAP calls?

  • Is your corporate proxy listening on port 80? Does it require authentication? – sybreon Sep 3 '10 at 3:16
  • Yes it's listening on port 80, no authentication required. – alimack Sep 4 '10 at 13:11
7

Create a setenv.sh (or setenv.bat if running windows), if you don't already have one, and add the following java options:

JAVA_OPTS="-Dhttp.proxySet=true -Dhttp.proxyHost=<proxy_hostname> -Dhttp.proxyPort=<port_number> -Dhttp.nonProxyHosts=<domain_one>|<domain two> $JAVA_OPTS"

This should work nicely.

| improve this answer | |
2

You can implement HTTP proxy, https proxy and non-http proxy also in tomcat. You need to update two files i.e, ../bin/Catalina.sh and ../conf/cataliana.properties.

Detailed configuration and steps are mentioned here : http://w3devops.com/add-http-https-proxy-http-non-proxy-jenkins-via-tomcat-server/

| improve this answer | |
0

If you only need soap calls to go via proxy, you can use jproxyloader. With this library you can pass soap calls via proxy and all the other calls will not use proxy. See http://jproxyloader.sourceforge.net/examples/web-application-on-tomcat.html for complete setup.

| improve this answer | |
-1

To get tomcat running inside my docker container I used the following settings:

JAVA_OPTS=-Dhttps.proxyHost=PROXYHOST -Dhttps.proxyPort=PROXYPORT -DproxySet=true -DproxyHost=PROXYHOST -DproxyPort=PROXYPORT

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.