I posted this a few days ago: Unable to write to root partition

We thought that an add on card may have been conflicting with the motherboard, so we installed a new motherboard. After that everything worked fine, and we were able to run the server for two days without any problems. Now all of a sudden, we're getting the same error (read only filesystem).

The question is, why did the HD take two days to fail again? Is this normal? Is it a sign that something more than the HD is broken?


  • 3
    I hope you've used the two good days to ensure you had a secure backup – Chopper3 Sep 2 '10 at 18:28

Bad disks don't always fail immediately - they only fail when a bad sector is written to or read from, so they can sometimes run for a while before falling over. I hope you did a backup in those two days.

  • 1
    Also, just because it hasn't fallen over yet doesn't mean it isn't complaining - keep an eye on dmesg or /var/log/messages. – James L Sep 2 '10 at 17:59

To add to what James said, you also can have a hard drive that only fails when it gets hot.

Whatever the cause for the problems, if I were you I'd replace the drive immediately, restore it from the good clean backup you made during that two days when it was running fine, and make sure you have smartd turned on with your new drive.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy