I have setup an Exchange 2010 environment with an Edge Server, Hub Trans/Client Access Server, and 2 Mailbox Servers in a DAG. Today I pointed the mx record to my Edge Server and am receiving the following:

Attempting to send test email message to test.account@1.dev.example.com using MX 
  Delivery of the test message failed. 
   Additional Details 
  Server returned status code 550 - Mailbox unavailable. The server response was: 5.7.1 Unable to relay
Exception details:
Message: Mailbox unavailable. The server response was: 5.7.1 Unable to relay
Type: System.Net.Mail.SmtpFailedRecipientException
Stack trace:
at System.Net.Mail.SmtpTransport.SendMail(MailAddress sender, MailAddressCollection recipients, String deliveryNotify, SmtpFailedRecipientException& exception)
at System.Net.Mail.SmtpClient.Send(MailMessage message)
at Microsoft.Exchange.Tools.ExRca.Tests.SmtpMessageTest.PerformTestReally()

I have setup the Edge Subscription on the Hub Transport, Added an A record to DNS for the Edge Server, Added the Hub/CAS to the Edge Server's Hosts file but yet still get this error. I just tried cmd "start-edgesyncronization" which errors saying "unable to contact the EdgeSync Service.

Event Log shows:

Log Name:      Application
Source:        MSExchange Message Security
Date:          9/2/2010 2:10:24 PM
Event ID:      1010
Task Category: EdgeCredentialService
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      MYEDGE.SERVER.local
Microsoft Exchange Edge server has not been updated by EdgeSync since 8/30/2010 10:05:17 PM (UTC Time).  Please confirm that the EdgeSync service is running.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">

It appears that EdgeSync is not running, but I am stumped.

  • so i have ran test-edgesyncronization on the Hub Transport and it fails saying that "the edgesync lease has expired. Might indicate edgesync service is not running" looks to be the root of the issue..but i am unable to contact the EdgeSync Service to start it in shell??
    – Chase
    Sep 2, 2010 at 20:38

1 Answer 1


Okay so I was able to solve this issue on the THIRD attempt of what was in my mind the same steps.

  1. removed the edgesubscription from the Hub Transport in EMC
  2. on Edge Server, ran "new-edgesubscription -filename "c:\exchange3.xml"", and imported that new xml to the hub server edge subscriptions.
  3. restarted both servers
  4. on Hub Server, ran "start-edgesubscription" SUCCESS something about doing it three times, I don't know :)

*I already had both the Hub and Edge server Hosts files including the opposite server's ip and name, as well as an A name record set in DNS for the Edge Server. Firewalls were off but if not, then proper ports need to be allowed

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.