I am currently unable to receive incoming mail in my Exchange 2010 Environment. it appears to be related to EdgeSyncronization, so i have ran test-edgesyncronization on the Hub Transport and it fails saying that "the edgesync lease has expired. Might indicate edgesync service is not running" looks to be the root of the issue..but i am unable to contact the EdgeSync Service to start it in shell. I setup a new Edge Subscription between my Edge Transport and Hub Transport/CAS but I still receive the same error. I have added both servers to each of their hosts files to be sure that the IPs are resolved, and created a record in DNS for the Edge Server. It just seems to be the EdgeSync which I cannot get started.

2 Answers 2


Okay so I was able to solve this issue on the THIRD attempt of what was in my mind the same steps.

  1. removed the edgesubscription from the Hub Transport in EMC
  2. on Edge Server, ran "new-edgesubscription -filename "c:\exchange3.xml"", and imported that new xml to the hub server edge subscriptions.
  3. restarted both servers
  4. on Hub Server, ran "start-edgesubscription" SUCCESS something about doing it three times, I don't know :)

*I already had both the Hub and Edge server Hosts files including the opposite server's ip and name, as well as an A name record set in DNS for the Edge Server. Firewalls were off but if not, then proper ports need to be allowed


We have a similar problem solved with sp1 for exchange 2010. Do you already installed it?

  • yes, I am actually working with R2 latest with rollup 4. I have re-subscribed the Edge Server in the Hub Transport, but cannot start the EdgeSync process
    – Chase
    Sep 2, 2010 at 21:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.