Good night! I can't login through GDM but can via terminal. Also I can't change layout but successfully do it via terminal.

This is example of /var/log/messages endline:

gdm-simple-greeter[...]: Couldn't enumerate devices
...the permission of the setuid helper is not correct...
And this "permission of the setuid" is everywhere in GDM logs. What the problem is?


Apologies for just posting links but I cannot reproduce the problem myself. I hope this is useful none the less.

There is a thread on this problem on ubuntuforums.org

The solution there was

  • log in tty1 console as root
  • stop gdm
  • startx
  • Now if you are able to see the desktop, connect to the internet and reinstall dbus related stuff from synaptic.

Another thread suggests the following command may also work

sudo apt-get install --reinstall gnome
  • I tried this, but can't stop gdm. This logon window is popups again and again. Maybe I am doing something wrong? – Clark Sep 6 '10 at 22:12
  • You could re-install the "dbus related stuff" from the console on tty1. You get there using (Ctrl+Alt+F1). Use apt-get to install packages. I cannot provide much help as I cannot reproduce the problem. Sorry – Richard Holloway Sep 7 '10 at 11:37
  • Reinstalling dbus (rather than gnome, which I didn't try) solved a similar problem for me on CentOS 6 – Nicola Musatti Aug 28 '13 at 14:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.