4

When I run sqlplus I get the following error:

#sqlplus
Error 46 initializing SQL*Plus  
HTTP proxy setting has incorrect value  
SP2-1502: The HTTP proxy server specified by http_proxy is not accessible

I've just installed the oracle instant client on fedora 12 by doing the following:

I downloaded the rpms from http://www.oracle.com/technetwork/topics/linuxsoft-082809.html

  • oracle-instantclient11.2-basic-11.2.0.1.0-1.i386.rpm
  • oracle-instantclient11.2-devel-11.2.0.1.0-1.i386.rpm
  • oracle-instantclient11.2-jdbc-11.2.0.1.0-1.i386.rpm
  • oracle-instantclient11.2-odbc-11.2.0.1.0-1.i386.rpm
  • oracle-instantclient11.2-sqlplus-11.2.0.1.0-1.i386.rpm
  • oracle-instantclient11.2-tools-11.2.0.1.0-1.i386.rpm

I then installed them all using rpm

In addition I added this to my /etc/bashrc file and restarted the shell:

export ORACLE_HOME=/usr/lib/oracle/11.2/client  
export LD_LIBRARY=/usr/lib/oracle/11.2/client/lib/  

OS: Fedora 12, 2.6.32.16-150.fc12.i686.PAE

This is a VMWare vm - that doesn't have access to the internet.

Perhaps I be using the i686 versions?

Thanks SF

3 Answers 3

3

The only thing that worked for me was to set http_proxy to blank:

export http_proxy=

Then run SQL Plus

2

sqlplus uses the http_proxy and no_proxy environment variables to determine if proxy is used. To bypass the proxy settings then both these values need to be unset.

unset http_proxy
unset no_proxy

or

export http_proxy=
export no_proxy=
1

Turns out I had set my password to the wrong value in profile.d/proxy.sh

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .