0

I'm having trouble installing subversion on fedora. when i run:

yum install subversion

I get the following error:

Transaction Check Error: package cyrus-sasl-lib-2.1.22-8.fc8.x86_64 (which is newer than cyrus-sasl-lib-2.1.22-7.i386) is already installed package openldap-2.3.39-3.fc8.x86_64 (which is newer than openldap-2.3.38-3.fc8.i386) is already installed file /usr/share/man/man5/ldap.conf.5.gz from install of openldap-2.3.38-3.fc8.i386 conflicts with file from package openldap-2.3.39-3.fc8.x86_64 file /usr/share/man/man5/ldif.5.gz from install of openldap-2.3.38-3.fc8.i386 conflicts with file from package openldap-2.3.39-3.fc8.x86_64

Error Summary

0

Sounds like you need to first upgrade your existing packages. I've seen a similar behaviour on RHEL when the packages were out of date and I tried to install ImageMagick. For some reason yum is (sometimes) unable to calculate the dependencies if packages are outdated.

So, run first yum update and after that yum install subversion. Though you seem to be running an ancient Fedora 8, so I'm not sure if that works ...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.