I created an ASP.net MVC developed web application and I am trying to set up IIS.

The Error: Http error 500.19, error code 0x80070005, Cannot read configuration file due to insufficient permissions, config file: C:\inetpub\wwwroot\BudgetManagerMain\BudgetManager\web.config

If I set the AppPool to use 'administrator' i have no problems and can access the site just fine. If i set to NETWORK SERVICE (or anything else including self-created admin or non-admin user accounts), i get the above error.

Things I have tried:

  1. identity for Application pool named 'test' is 'NetworkService'
  2. Set full access privs for wwwroot and all children files/folders
  3. verified effective permissions and NETWORK SERVICE has full access.
  4. Authentication on my site is set for anonymous and running under Application Pool Identity
  5. I do not have any physical path credentials set on the website
  6. confirmed website is set to run under the application pool named 'test'

using Process Monitor, here is a summary of what i found on the ACCESS DENIED event


  1. Class: File System
  2. Operation: CreateFile
  3. Result: Access Denied
  4. Path: ..\web.config

  1. Desired Access: Generic Read
  2. Disposition: Open
  3. Options: Sybnchronous IO Non-Alert, Non-Directory file
  4. Attributes: N
  5. ShareMode: Read
  6. AllocaitonSize: n/a


...lots of stuff that seems irrelevant


  • Does C:\inetpub\wwwroot\BudgetManagerMain\BudgetManager\web.config exist? Commented Dec 17, 2012 at 0:11

2 Answers 2


Simplest interpretation of the error: IIS has detected a folder called


and tried to read a web.config file from that location, but the Application Pool account hasn't been able to read a web.config file in that folder.

This is probably going to be because of NTFS permissions preventing the Network Service account (you noted above) from accessing that folder.

The Application Pool Account requires Read access to all folders and web.config files within the website.


You could try deleting the relevant folder in the Temporary ASP.NET Files folder (C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files in XP). Maybe there's some kind of caching going on?

  • Thanks but no-go. there were files in there but removing and restarting the site did nothing. I checked .net 4.0 temp folder and there was nothing there.
    – Re-Pieper
    Commented Sep 8, 2010 at 22:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .