We have a server named slc-app-01 and an ASP.NET application in the default website configured as printflow. I set up a CNAME in DNS for printflow to point at slc-app-01 so the application could be accessed via http://printflow/printflow.

The problem is that when the application is accessed via http://printflow/printflow it returns:

403.1 Forbidden: Execute access is denied.

But when accessed via http://slc-app-01/printflow it works fine.

This has worked fine for over a year. The only thing I can think that we recently changed was installing .NET 4.0 and registering ASP.NET 4.0 with IIS. The application however is still configured for .NET 2.0 and we created a separate AppPool for the 4.0 application.

Thanks for any help.

  • 1
    Do you have IIS configured to accept the printflow host header? – Coding Gorilla Sep 13 '10 at 20:00

Have you added "printflow" to the Host Headers for the website in IIS?

  • No, this isn't really related to host-headers. I just want the CNAME to access the Default Website. Host headers are for mapping the same IP address to a different configured site based on the HOST HTTP header. – joshperry Sep 13 '10 at 20:24
  • The website, running on IIS, will not know what to do with an incoming HTTP request for a website called "printflow". That name must be added to the specific sites Host Headers, so your IIS will know which website to serve up when it receives that request. – Izzy Sep 13 '10 at 20:27
  • Did you just recently create that CNAME record, or has it been in place (and working) for a long time? – Izzy Sep 13 '10 at 20:30
  • Sure it will, do it all the time. The default website with no hostheader configured will answer any inbound HTTP request regardless of the HOST header (unless of course there is another site configured with that host header). – joshperry Sep 13 '10 at 20:31
  • Yeah, it's worked for over a year. – joshperry Sep 13 '10 at 20:32

You could check the following things:

  1. Is there a web proxy involved when you try to access the server? Do you need to configure it for that host header?
  2. What happens when you do a nslookup printflow? Does it resolve to the right IP address?
  3. Did you check the http bindings of the website? Does it accept the "printflow" http host header?

Turned out to be a HOST Header problem after-all. Someone had configured a site with printflow as a hostheader and it was co-opting all of the requests. Since this rogue site was configured with "None" for "Execute Permissions" it was throwing a 403.1 instead of a 404 for "*.aspx, asmx, etc..." even though the site was void of any files.

  • Bahhh... I told you so! – Izzy Sep 13 '10 at 22:12
  • Haha, unfortunately the problem wasn't because of a lack of a hostheader. – joshperry Sep 16 '10 at 16:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.