I installed xdebug from source, but also tried my package manager (separately) and they both are loaded correctly (verified by restarting Apache and seeing the xdebug copyright info in phpinfo()) but they do not dump profiling information.

Out of the 40 different attempts of configuration it logged once or twice but I lost what I did, I tried with first only loading the module in php.ini with no settings, but it didn't log to /tmp/. I tried many different settings but my current is now:

xdebug.profiler_enable = Off
xdebug.profiler_enable_trigger = 1
xdebug.profiler_output_dir = "/tmp/"
xdebug.profiler_output_name = "profiler.%t"  

Of course I call my script through, which is for enable_trigger.

Do you know why it would not dump profiler information? nobody (Arch Linux) can write to /tmp/ as it has before, so I'm sure it is not a permissions error. Apache's error_log does not tell me anything about xdebug either, as it has loaded correctly. It just does not "work"!

EDIT: I made a subfolder "xdebug_profiles" in /tmp/ and chown'ed it to nobody, and now it works flawlessly. I'm not sure why it couldn't write before, I guess it's just a caveat with nobody on Arch.

I answered my own question , not enough points to answer it or comment, so consider this answered.

1 Answer 1


Make a subfolder "xdebug_profiles" in /tmp/ and chown it to nobody, it will now work flawlessly. I'm not sure why it didn't write before, I guess it's just a caveat with nobody on Arch.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy