I'm having an incredibly difficult time trying to get my red hat server to sync its time to our 2K3 domain controller. I've been through numerous ntp.conf revisions and it always ends up that the domain controller is not even listed as a contender in the ntpq output. Even with my ntp.conf file at is most simple state:

server my.server.ip

it still fails to sync. It never receives an asterisk to indicate its synced up. If I include the local clock fudged to stratum 10 ntpd will even choose that over our domain controller. Something is quite wrong but I can't seem to figure out what. This command works as expected:

ntpdate my.server.ip

it sets the system clock appropriately so I believe communications are working just fine.

Please help. Thanks, Donovan

  • Have you tried using wireshark to examine the network traffic? Maybe something else weird is going on? – shapr Oct 1 '10 at 18:14
  • What does ntpq -p say? – marcoc Oct 1 '10 at 20:24
  • ntpq -p is whats giving me the output for checking the sync status. From my reading the time server in use should have an asterisk next to it. I engineered the config file to only have my single server and still no asterisk. Server still looses time too. Also, ntpdate -[mytimeserver] will update the time appropriately. – Digital ink Oct 19 '10 at 0:18

"The W32Time service is not a full-featured NTP solution that meets time-sensitive application needs."

IMHO it gives an answer to a simple ntpdate command, but it advertises itself as a non-reliable source to any ntpd client.

| improve this answer | |

You can add -x to the start of OPTIONS= in /etc/sysconfig/ntpd. This will force a one time synchronization when the service starts.

For example: OPTIONS="-x -u ntp:ntp -p /var/run/ntpd.pid"

If you restart the ntpd service and it fails to do a one time synchronization, go straight to syslog and post the related output here.

| improve this answer | |
  • is that test still relevant if I am doing ntpdate -[mytimeserver] right before I start the service? – Digital ink Oct 19 '10 at 0:19
  • You say that ntpdate my.server.ip works as expected. Let's focus on what's preventing ntpd from working. Paste up your /etc/ntp.conf and the output from syslog. – Aaron Copley Oct 19 '10 at 13:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.