I have a windows xp machine on one domain with a shared folder (advanced file sharing) and is limited to \\machine1\Administrator (only he can see the folder and change files).

the problem is that, when I access the machine in a win7 64bit client machine, it doesn't ask me for the user/pass (the administrator of machine1). When I try to access the folder, it says I cannot access it (which is correct).

Please note both machines are on different domains.

What is going on, why doesn't it ask for my password? Any tips to troubleshoot this?


This is almost definitely due to the fact that user supplied by the source machine exists in the target's domain. When that happens, Windows will happily supply the password for the User to the target. In this case the passwords are not the same, so you get access-denied.

To work around this, when you map the drive supply a specific credential. This pre-supplies the username (with domain/machine!) so the connection will complete.

  • Current win7 user in machine2 doesn't exist in machine1. Tried your workaround but I get this message when trying to connect: "The network folder specified is currently mapped using a different user name and password. To connect using a different user name and password, first disconnect any existing mappings to this network share." So... maybe some caching issues? What can I cleanup (caches)? – AlfaTeK Sep 14 '10 at 18:38
  • Right-click on Network Places and select Disconnect Network Drive. You may have a lingering connection to that machine that needs clearing before you can map that drive using new credentials. – sysadmin1138 Sep 14 '10 at 18:53
  • Also take a look in Credential Manager on the Win 7 computer and see if there are any stored credentials there. – joeqwerty Sep 14 '10 at 20:05
  • Tried everything and it still doesn't ask for the username/password, just gives "cannot access" error.... Also tried the net use * delete command – AlfaTeK Sep 15 '10 at 13:43
  • +1 This works fine for me, except I'd prefer to not tell my team to map a drive letter. Surely there's a more elegant approach. – Lee Grissom Mar 14 '13 at 22:19

The problem is with Windows trying to keep your credentials for a network share. It tries to connect to the share with the credentials you might have supplied earlier, but those are rejected. To reset all connections you might have to servers or other machines, in a prompt type:


It will ask if you want to break all current connections. Type yes. Now try to connect again.

  • As joeqwerty suggested in a comment, the above command can be executed through the credential manager in Win7 too. – Karst Lok Sep 14 '10 at 20:11
  • Ouch, deleting using * is a bit overkill. A better route is to first type NET USE at the command prompt, then you can see a list of all connections and individually delete the problematic ones: net use \\server\folder /d – Lee Grissom Mar 14 '13 at 22:15

Not the answer you're looking for? Browse other questions tagged or ask your own question.