I have a less than one month old server on which Windows Server 2008 R2 is installed. I have a 2 mirrored disk drives in there. I attempted a RAM upgrade, which did not go well possibly due to memory density issues. The server refused to even POST, so I rolled back the upgrade and installed all of the original RAM back. I should mention that I probably turned the server on and off about 12-15 times during the upgrade process due to trying different RAM combinations. After I reinstalled the original RAM, the server started up fine, but the boot screen presented me with:

Windows Server 2008 Windows Server 2008 - Secondary Plex

I chose each option after the other didn't work, but the screen would blank out at the Windows Loading progress bar. Even the Windows icon would not show up.

I then tried booting up in safe mode, which went through fine. I resynchronized the mirror drive, and then tried rebooting again, but same problem, stalled at the loading progress screen. I booted into safe mode, then removed the mirror drive, then restarted, but same issue.

I downloaded EasyBCD in safe mode then tried the option of fixing the bootloader, but same problem again.

Event logs don't show anything useful as far as what's causing the problem. Do I need to fix the MBR somehow due to the previous mirrored setup?

EDIT 09/16: A Dell tech came out and replaced the mobo, ram, and CPU, and after a few reboots, the system comes up fine now. However, after I enabled Virtualization in BIOS, the system again started exhibiting the problems I had to begin with. I disabled VT and started it up again, it came up fine.

I then tried to flash the BIOS as the one on the new mobo was from January 2010. I ran the installler through Windows then allowed it to restart, but the server never comes back up. I let it sit there for at least 45 minutes, then did a hard reboot. BIOS still shows the old version installed! I tried the same process again, but don't have any high hopes for it. The whole reason I bought the server was for HV VT, and now it seems to be causing this problem. Argh

  • Ok, now this is really messed up. I disconnected the 2 mirrored drives and tried to boot off a Windows Server 2008 DVD, but after it loads the files, it displays the Windows logo animation, then restarts. I don't even know where to go with this now, if it can't even boot of a DVD but has no problems booting into safe mode. I tried to also launch Repair Your Computer through the F8 console, but after it loads the files, the screen just blanks out. Really hope there's not some hardware issue, BIOS/POST does not show any problems. Frustrating as all hell
    – Agent
    Sep 15, 2010 at 2:33
  • 1
    What kind of server are you running? Have you tried running Memtest? Maybe the RAM got damaged in the swap. I would hazard the guess that if it's rebooting when loading the DVD, that there's a memory fault somewhere, since you took the drives out of the equation... Sep 15, 2010 at 20:31

3 Answers 3


Sometimes the best answer is to burn it down and start from scratch. Since it's less than a month old, I'm going to guess (rightly or wrongly) that you don't have much invested in it yet. Would you be able to set up a new mirror and reinstall? You'll find out real quick if you have a hardware problem then.

  • 1
    I've worked on the server quite a bit in the past month, mostly on building out a Hyper-V lab environment, Ex2010, SP2010, SQL, and AD. I've backed up just the VHDs for the HV environment, but since I'm still in the learning phase of it, I don't know how many things may go wrong if I just move the VHDs to a fresh install. I'm doubtful anything will, but in any case, I'd rather fix this problem so I have the know-how in case I run into the issue again. I'm pretty sure it's not a hardware issue at this point, I think the constant reboots just borked Windows.
    – Agent
    Sep 15, 2010 at 0:52
  • 1
    @Agent, I'll give you a +1 on your comment to figure it out. I'm the same way myself. I drive myself nuts if I can't figure out what's wrong with something. Anyways, it's just my $.02. I can't really give you any other helpful tips on the problem, but there is documentation on moving VHDs between hosts : blogs.technet.com/b/brucecowper/archive/2010/04/09/… Sep 15, 2010 at 1:00
  • Thanks for the link (and the +1). It seems from the link that reattaching the VHDs should work just fine, but I know I'm going to run into this problem at some point. A lot of managers and clients really hate the words "rebuild/reinstall", even when the time invested in finding a solution overtakes the time to rebuild from scratch.
    – Agent
    Sep 15, 2010 at 1:08

I am glad I founf this site. For the future you can use a backup program so that it will be quicker and easeier to restore your server. I will recommend Acronis it has helped me with restoring my entire servers and my local machines.

It is a great product. you should try it.


After nearly a month of working on and off this issue, it was finally resolved last week. It may have been a combination of problems that got stacked onto one another, but here's the flow of the issues:

1) RAM upgrade does not go smoothly

2) Dell support asks me to troubleshoot over phone, doesn't go anywhere

3) Dell technician comes on site and replaces 2 of the 4 RAM, motherboard, and CPU

4) Server now starts fine, leading me to believe that the new RAM upgrade sticks were not compatible, and 1 or 2 of the old ones somehow got damaged in the switch

5) I reboot, then enable virtualization in BIOS since the mobo swap defaulted to turning it off. Server again starts showing the same symptoms and problems as I originally had!

6) I turn off VTX then reboot, server comes up fine. VTX seems to be an issue now, which is a big problem, considering that's what I bought it for

7) I swap sticks of RAM in and out, the only combo that works with VTX enabled is 2 of the new sticks, giving me just 2 GB total RAM in the system.

8) Dell says to flash my BIOS, which I try to do through Windows. Windows says BIOS is upgraded fine, then asks to reboot. I let it reboot, but it never fully shuts down. After I manually shut it down then start it up, the BIOS version is still the old one

9) Can't really upgrade BIOS with a floppy, since server does not have one. Trying to flash BIOS through Dell's boot cd is a hassle and a half, and I eventually give up on it

10) I check Kingston's site for compatible RAM, then order 2 4GB sticks. I pop them into the server, it comes up perfectly fine, and with VTX enable

11) Now the server is running fine with 10 GB of RAM, finally!

I think the RAM I had originally ordered should have been compatible in theory, but it's density config may not have been compatible with my mobo, from what a colleague told me.

Lesson: Next time, I won't just order from specs, I will actually check compatibility from the big names (Kingston, Crucial, etc). Any slight performance decrease I will see from these name brands and their higher cost, I will gladly deal with rather than the 3-4 week long downtime because of incompatible ram.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.