When I try to access a share folder, say \\share-folder, I get the following error message:

logon failure: account currently disabled

This seems strange to me, since there is no 'account' to be disabled: I wasn't even presented with a login dialog. (The account that I would have used isn't disabled...)

The client (the one with the error message) is running Windows XP SP3. The server is running Windows 7; its firewall is set to allow file sharing from any computer in our /16 CIDR (the client, naturally, is in this large block).

How can I get the server to recognize the client? I can change settings on either.

  • 1
    Is the environment AD or Workgroup ?
    – JS.
    Sep 15, 2010 at 15:09
  • Workgroup. Good question, I should have mentioned that.
    – Charles
    Sep 15, 2010 at 21:44
  • Charles, can you confirm that you can access the share from other clients. What share\ntfs permissions are set on the folder ? Does the user account on the XP machine have a blank password?
    – JS.
    Sep 20, 2010 at 16:02
  • I have access to the share from every other computer, including several XP machines. I have a special 'share' user that has all permissions on that folder, and this is the user I connect through.
    – Charles
    Sep 20, 2010 at 23:54
  • Is the computers account tombstoned?
    – dc5553
    Apr 27, 2012 at 12:15

10 Answers 10


It sounds like your client machine is not giving you the opportunity to specify credentials for the "share" username that you have created on your server.

In a workgroup environment, the easiest way to force Windows to log into a network share with specific credentials is as follows:

net use \\server\share /delete
net use \\server\share /user:server\username <password>

Mapping a drive letter to the share is optional, e.g.:

net use \\server\share /delete
net use S: /delete
net use S: \\server\share /user:server\username <password>

In your specific case, the username above would be "share".

By the way: how many clients are accessing this "server" concurrently? Windows 7 has a limit of 20 connections, up from 10 in Windows XP. It's been a long time since I've worked in an environment that was using a Windows client OS as a file server, but it seems plausible that, if the limit were reached, additional connections could be denied with a non-intuitive error message.

  • Excellent! I'll do this straightaway. As for the number of clients, it should be very few... probably no more than 6 or 10.
    – Charles
    Sep 26, 2010 at 4:09
  • 1
    Thanks so much! Had a stripped down copy of XP that does not include the GUI based networking. This saved my life. Aug 15, 2014 at 18:07

Take a look at the Credential Manager on the XP machine.

Control Panel -> User Accounts -> Manage My Network Passwords (on left of screen)

Here you will see a list of stored usernames\passwords and the server\share that they are used against.

Delete the server\share in question, and next time you connect to the share it should prompt you for a username and password.


Another thing to check would be the number of open sessions on the Windows 7 machine hosting the share. Windows 7 has a limit of 10 concurrent sessions.

You can check this in computer management on the Windows 7 machine -

On the start menu right click "computer" and choose manage, then navigate to System Tools - Shared folders - Open Sessions.

  • I'll try that, but I'd be surprised if it worked. The server is new, the client has never connected to it before.
    – Charles
    Sep 15, 2010 at 14:09
  • Manage My Network Passwords had nothing on the XP machine. The Win7 server had only 0 concurrent sessions at the time -- and so far I've only set this up on 5 machines, so running into that limit shouldn't be possible. Any other thoughts?
    – Charles
    Sep 17, 2010 at 19:05
  • Manage my network passwords worked for me! (I had an existing account that stopped working when the server was rebuilt)
    – MrTrick
    Oct 2, 2015 at 0:43

This is caused by there not being a password on your account on the pc you are trying to connect From

Click through Control Panel - user accounts and set a password for your current login

then when you try to access the network share it will prompt for a username and password. use the correct one to access the share at this point.

  • 1
    Yup. I tried several others things until your simple solution solved it.
    – JayJay123
    Jun 25, 2020 at 8:19
  • 1
    This helped me!
    – Calab
    Sep 15, 2020 at 0:03

Try typing 'net use' at the command prompt and see if any credentials for that server have been cached and delete accordingly.

  • The client says "New connections will be remembered. There are no entries in the list." -- that is, it has no credentials cached. But this did solve a different problem I had, so +1 for that.
    – Charles
    Sep 17, 2010 at 19:04

Can you verify if you have Antivirus running on either of the machines? Also, check the Application Event Viewer when you get this error. You might get some clue there :)

Happy troubleshooting

  • I didn't see anything useful in the Event Viewer. The machines are both running Symantec AV but that doesn't seem to be the problem.
    – Charles
    Sep 21, 2010 at 19:29
  • interesting.. can you add that folder in the exception list on Win 7 machine and check if that works Sep 21, 2010 at 21:48

Which versions of Windows are you running? Win7 Home Premium/Professional/Ultimate? Windows XP Home/Professional?

Do you have simple file sharing turned on or off?

Have you tried to map the share to a drive and tell it to connect using a different username?

Edit: I am also curious which system is throwing the account disabled error. Can you look in your event viewer to see? The event log should also tell you exactly which account it is referring to. My thought is that it is trying to use the Guest account.

  • XP Pro SP3 and 7 Pro. Simple file sharing is turned off. But mapping the share seems to work! (+1) But the password isn't saved -- if I turn on the computer the drive fails to reconnect (with the standard error message) and I'm in the original situation ("account currently disabled"). I can reconnect the same way, but how can I make it save the password?
    – Charles
    Sep 21, 2010 at 19:32
  • It should save the password as long as you have reconnect on logon checked... You could try making a user on the XP machine with the same username and password as the one on the Win 7 machine.
    – slacker
    Sep 22, 2010 at 14:22

My guess is that it has something to do with incompatible security settings in local or group policy. Look through the options in the Group Policy Editor on the Windows 7 box and see what you can find. It's most likely somewhere under: Computer Configuration --> Windows Settings --> Security Settings --> Local Policies --> User Rights Assignment or Security Options.

Are these domain members, by the way, or workgroup computers?

Note: Launch the Local Group Policy Editor by running "gpedit.msc" from the Run prompt.

  • Workgroup computers.
    – Charles
    Sep 24, 2010 at 18:06

I have several computers on a AD domain - and "suddenly" one of my Win7 boxes could not log into a Linux SMB share that I use as a main file store.

There were other machines, including Win7 machines, that were able to access it just fine.

The solution about editing the "Manage Credentials" list was spot on! I found a cached credential for the SMB server, deleted it, and all was well.


On the Win7 'server' is there a user with the same name as the user you're logged into the XP machine with? If so, you won't ever get a password prompt as Windows will try to use the session credentials by default, and this is failing with bad password instead of "user doesn't exist" which is why it's not asking you for replacement credentials.

In fact it might be that the account is disabled, so it's flat-out denying the connection, rather than spotting the bad password and asking you to retry.


You have to enable the Guest account on both ends of the anonymous share connection. However a 2008R2 server accessing an anonymous share will still prompt for a user name and password for some reason I have not tracked down yet. But typing in Guest with blank password makes the connection.

  • I don't want to allow anonymous access, though -- I want to use a particular account.
    – Charles
    Oct 14, 2010 at 19:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.