We have a Sonicwall Pro 2040 and are having issues with our VPN clients. None are able to connect as they all stop at the point of acquiring an ip address.

I have tried all the ideas that I have come across including turning nat traversal on and off. Have tried using the sonicwall dhcp server and the network dhcp server. Have created a new policy, and no change. If I turn off the virtual IP address I am able to connect just fine. I need the vpn clients to be able to reach other machines in the domain though, so I need the virtual ip. I am completely at a loss at this point and it is looking like this is going to eat up my weekend.

Anyone have any experience with this or any possible ideas?


In your description it is a bit confusing, where you say: "If I turn off the virtual IP address I am able to connect just fine. I need the vpn clients to be able to reach other machines in the domain though, so I need the virtual ip."

What does that really mean - is it that you turned off DHCP, is that what you mean by "turn off the virtual IP address"?

Even though you already know how to set up the Sonicwall, since there is a problem it could be prudent for you to review the process for setting up. Here is a site that may be a different description and so may provide an alternate viewpoint:

  • Sorry that it was confusing. In the link you sent you'll see there is a check box that says Use DHCP to assign a Virtual IP. If I un check that box I can get a stable VPN connection but I am not able to connect to anything behind the firewall. I need to be able to communicate with devices behind the firewall and therefore I need DHCP to work,but it seems it won't. – joshlrogers Sep 18 '10 at 19:18
  • OK, so that confirms what I thought you meant.What address does the VPN client have when DHCP is not used? – Beel Sep 18 '10 at 20:14
  • Oops - not finished. I;m thinking that when you get an address from DHCP, the SOnicwall has a routing rule that allows the traffic to find its way from the client to a target and back. And when DHCP is not used then whatever address the client uses, is not properly routed. Perhaps you could try manually assigning one of the DHCP addresses. – Beel Sep 18 '10 at 20:17
  • @Beel Manually assigning does work, but that is easy for me for my end users not so much. I have new information though. I got wireshark up and going on the DHCP server and I see that the firewall is successfully sending the DHCP request and the DHCP server assigns an ip. I put wireshark on the client and they never receive a dhcp assignment so it seems the firewall is not passing the DHCP request back to the VPN client. I also checked my rules and I have Lan->VPN Allow Any – joshlrogers Sep 18 '10 at 21:41
  • Yes, josh, I agree that manually setting addresses is not the actual solution. The thought was to just see if that address range worked.<br /><br />What OS version is the Sonicwall? Can you not allow the Sonicwall to be the DHCP server, instead of an external DHCP server? And, can you log the outgoing traffic from the Sonicwall so as to see if DHCP is leaving it, as opposed to not being received by the client? – Beel Sep 18 '10 at 22:29

With the Virtual adapter set to "none", one of the keys is to have "NAT Traversal = enabled" - Sonicwall / VPN / Advanced

The other main consideration is to give the user access to the office Lan. My Office LAN network is defined as the "Lan Subnet" in the sonicwall. Under Local Users (in the case of no AD integration), make sure the User is allowed access to "Lan Subnets" in my case.


Had the same issue. I upgraded to the latest Sonicwall client then disabled Nat Traversal and set the interface selection to LAN Only then I was able to connect properly.


I know this is an old post, but it came up for me when searching for a solution to the "no IP" issue.

I finally figured out what my issue was. Hopefully, this will help someone else...

In SonicWall, go to VPN > Settings Click the settings button for your VPN Policy Go to the CLIENT tab Click the drop-down for VIRTUAL ADAPTER SETTINGS Select DHCP LEASE Save the settings


I turned off my router. I prayed to God for 30 seconds. I turned on my router.

The SonicWall Global VPN client continued on past the Acquiring IP Address and I got connected and I was able to login in to my remote desktop to do my work.

Problem solved.

  • 1
    Prayers' results are very much user-dependent. – Deer Hunter Mar 15 '15 at 17:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.