I have a Netgear VVG2000 VDSL router/modem from my ADSL provider. Its Ethernet ports are 10/100 and it doesn't have external wireless antennae, so I'd rather stick to my D-Link DIR-655 as the primary router. I'm connecting to my ISP using PPPoE. Therefore, my current configuration is this:

All wireless and wired devices --> D-Link router --> WAN port connected to LAN port on the Netgear --> PPPoE to ISP

The D-Link router is doing DHCP; I turned off DHCP on the Netgear. However, they're not in the same subnets -- the Netgear is at, the D-Link's WAN port gets, and the D-Link distributes IPs in the subnet.

However, I want to avoid double NAT (e.g. so that Windows Home Server Remote Access works properly). What I tried so far:

A) Use the hidden /mode.htm page on the router's website to put it in "Modem" mode and set up PPPoE on the D-Link. After doing this, the D-Link failed to get an IP using PPPoE.

B) Turned off NAT on the Netgear. After doing this, the Netgear acquires an IP from the ISP but there's no Internet connectivity from any device connected to the D-Link.

C) Switched NAT to "Bridge" on the Netgear. Result same as in B.

D) Put the D-Links IP address as the DMZ computer in the Netgear's configuration. This actually worked (including Windows Home Server automatic port forwarding so no double NAT) but the Internet connection got significantly slower. Speedtest.net and my ISP's internal speed test site both report a 6x slowdown (5Mbps instead of 30Mbps).

E) There's a similar question answered here but I'm concerned with this solution because it seems that all traffic will go through the external router (the Netgear in my case) and it doesn't support Gigabit Ethernet.

Ideally, I would want to dumb down the Netgear as much as possible, and use it only as the necessary bridge to my ISP. How can I do this?


You're on the right track with A. You want to disable DHCP, DNS, NAT, and everything possible on the Netgear VVG2000 and put it in bridge mode.

The parameters on your modem, like VCI and VPI and such, need to be the same on your D-Link.

Sounds like the issue you might have been having with A is that DHCP wasn't disabled on the VVG2000?

| improve this answer | |
  • Putting the Netgear in "Modem" mode automatically turned off DHCP, so it wasn't that. And I can't find a place to configure VCI and VPI on the D-Link, even though I do see them on the Netgear's status page. – user54642 Sep 18 '10 at 15:55

I turned on the bridge mode and I was able to connect after a minute or two. Try restarting everything. Also make sure that the Ethernet cable is in the LAN 1 slot

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy