I'm attempting to solve this problem...

... by reinstalling Samba, but I'm getting the following error:

# apt-get install samba
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libdns45 libisccc40 liblwres40 libbind9-40 libisccfg40 libisc45
Use 'apt-get autoremove' to remove them.
Suggested packages:
  openbsd-inetd inet-superserver smbldap-tools ldb-tools
The following NEW packages will be installed
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B/4780kB of archives.
After this operation, 12.7MB of additional disk space will be used.
Preconfiguring packages ...
Selecting previously deselected package samba.
(Reading database ... 56732 files and directories currently installed.)
Unpacking samba (from .../samba_2%3a3.2.5-4lenny13_amd64.deb) ...
Processing triggers for man-db ...
Setting up samba (2:3.2.5-4lenny13) ...
Generating /etc/default/samba...
Starting Samba daemons: nmbd failed!
invoke-rc.d: initscript samba, action "start" failed.
dpkg: error processing samba (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

Previously I had run these commands:

apt-get remove --purge samba
rm -fr /etc/samba/
rm -fr /var/log/samba/*
  • Either you somehow still have a running nmbd, or a stray pidfile, in which case kill the nmbd process, remove the pidfile, and run dpkg --configure nmbd;

  • or you're seeing the same error as before the reinstall, which was due not to samba itself but a dependency (such as libwbclient0 or libtalloc2 or libc6 or the kernel or the hardware). Does running nmbd -i also produce a stack trace? Did you upgrade one of the dependencies lately? Did you run a memory test lately?


I had the same problem, only I had manually disabled both smbd and nmbd before, but could not remember how I did it.

Check if you can start smbd and nmbd by trying to start both: /etc/init.d/_mbd start and then testing both to see if they're still running /etc/init.d/_mbd status. If they are still not running, try making sure the init conf files for both still exist: /etc/init/_mbd.conf.


Hmm, well these commands seemed to get the install working (but didn't fix my original issue):

apt-get remove --purge samba samba-common
apt-get install samba

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.