I am working on a machine running Windows Server 2008. Every program I have tried to run (firefox, notepad, wordpad) works fine, but if I right-click on any item on the desktop or the start menu and select "Run as Administrator" it freezes.

I can move the mouse around and open/close the start menu, but the items in the start menu do not change color when the mouse hovers over them.

I googled for answers for some time but had no luck. Does anyone have any ideas that I could try?

(Update: I forgot to mention that the machine is virtual and I am using VMWare Workstation. In order to answer the questions below, I have been going to the same snapshot of the system each time. This lets me start the system in the exact same place each time in order to answer your questions and test.)

(Update: When I run any process as administrator and it freezes, I can start task manager, but I cannot see the new process (notepad, etc...) )

7 Answers 7


So this is a little bit of a strech, but I have a hunch it is the answer you are looking for.

I run a Vista 64-bit machine that has the same problem you are speaking of. Turns out the problem is beause of UAC. For some reason UAC does not pop up the way it should and does in other places. On my machine I disabled UAC completely, rebooted, and the RunAs worked just fine. Good news in my situation is that I found another way to make the app work the way I wanted it to without needing RunAs and I was able to resetup UAC.

Server 2008 from what I understand is very like Vista, and hopefully this helps you.

  • Thanks for the good idea. How did you reset the UAC? I tried to reset it using the Control Panel but it just froze like before. I think this might be the problem though
    – user5795
    Jun 8, 2009 at 16:35
  • 1
    I do not have a Windows Server 2008 box, so I pulled this info from this website: computerperformance.co.uk/Longhorn/… If you open your Local Secuirty Policy, look under "Local Policies" and then look in "Security Options". Here you will find the UAC policies. The one you want is "UAC: Behaviour of the elevation prompt for administrator" and the default is "Prompt for consent". Change this value to "Elevate without prompting". My guess is you will need to restart your server to make this change take hold.
    – Matt
    Jun 9, 2009 at 1:26
  • This is a good idea, the "blanking" effect of the UAC prompt is probably causing a video driver issue.
    – Aidan Ryan
    Jun 26, 2009 at 0:44
  • Easiest way to disable UAC: Go Start -> Run -> Enter 'msconfig -> Select the 'Tools' tab -> Select 'Disable UAC' from the list -> Reboot. Aug 1, 2010 at 8:27

It may be more basic that you think: hardware fault. Just for fun, try chkdsk /r and see if any bad sectors are reported at the end. Hard drives fail, even new ones, RAID/Mirroring doesn't always report the error appropriately (particularly "hardware" RAID).

  • Thanks Froosh, I tried to run chkdsk /r but I need to run command prompt as administrator to do that. Also, I copied the virtual machine to another computer and still had the same problem, so I think it is probably not a hardware issue.
    – user5795
    Jun 3, 2009 at 13:47
  • Doh! I didn't think of that, my apologies! Agreed, if the VM runs elsewhere, hardware is pretty much excluded.
    – Froosh
    Jun 5, 2009 at 5:34

Use Filemon and Regmon from sysinternals to see what happens at that moment.


Can you try the following:

  1. Have you logged in as the administrator to confirm this does not happen on that acccount?
  2. Can you create a new account and verify the same problem occurs?

This will at least attempt to resolve if just a profile issue. I have run wk8 since the beta and am now using 2k8 R2 RC and have not experienced this problem at all.

Some more questions incase just an IO/Memory Issue:

  1. Are you running the HyperV role?
  2. If you have HyperV how many VM's running and what is the memory allocation on host system?

You could also try a search in the MSDN/Technet forums and see if anyone else experiences your issues. But the first 2 steps should help us narrow the problem down.

Updated: So you are running under VMWare. Is this workstation or ESX? Have you tried copying to another server and merging your snapshots to eliminate the Virtual disk subsystem as the issue?

Update 2: Have you tried doing a defrag/shrink of the virtual HD file? On the copy you created for VMPlayer testing, can you start up in safe mode, create a user with admin priviledges, login with this user then rename the %WINDIR%\Users\Administrator folder to %WINDIR%\Users\Administrator.old. Then try to login again as an administrator. This should fix a corrupt profile issue. If it works on the VMPlayer copy then you can look at doing the same on your 'production' copy

  • Thanks for your time Wayne. 1. When I log off and log on as "Administrator", it does not work. I waited about 20 minutes and then reverted back to the previous snapshot. I was able to restart the machine under my current login (which has admin privileges). Everything was the same after restarting. 2. I can open the control panel, but then the process will not finish. The mouse turns into the hour glass indefinitely (i.e. it freezes) I am pretty sure I am not running HyperV role.
    – user5795
    Jun 3, 2009 at 13:45
  • Hey Wayne. I'm using Workstation and I've opened the program in Vmware Player on another machine and it behaved the same. I only have one snapshot right now (I had to delete the other snapshots a while back).
    – user5795
    Jun 8, 2009 at 19:00

I had this issue on a Windows 2008 Server with Exchange 2007 which I needed to uninstall and decommission.

To fix this issue I did the following: 1. Booted into safe mode 2. Opened up MSConfig and went to the "Tools" tab 3. Ran "Disable UAC" 4. Reboot into normal mode

I was then able to uninstall Exchange (and run applications that required UAC elevation).


I see this issue as well, running SBS 2008 on Hyper-V Server 2008, with a fresh install. One point to note: I did leave the computer hung waiting for the UAC popup for a few hours at one point. When I returned, there were no messages, and the app (Computer Management) had not opened. I tried to open it again, and from that point on, UAC functioned correctly for every app that required it. Occasionally, I still see this after a restart, but not consistently.


I found that if I logged off and logged back on, this issue cleared itself up. So, for those of you in a production environment where a full reboot is super-painful, give that a shot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.