I am behind a corporate proxy server/firewall, and this firewall seems to not be too happy with my idea of local development. On my home computer (Mac/Leopard), I have MAMP running, with a rule in /etc/hosts that directs dev.example.com to, and I have a virtualhost set up in the httpd.conf file which works great for me.

However, at work, I set up the exact same configuration, but am not able to access dev.example.com, likely due to some address/DNS translation going on via the proxy server.

Here are the relevant details from Terminal:

$ ping dev.example.com
PING dev.example.com ( 56 data bytes
64 bytes from icmp_seq=0 ttl=64 time=0.025 ms
$ host dev.example.com
Host dev.example.com not found: 3(NXDOMAIN)

I've tried adding dev.example.com to the list of bypass addresses in System Preferences (the 'Bypass proxy settings for these Hosts & Domains' list), but that had no effect.

Is there any way I can develop locally using name-based hosts at work? I can access localhost, but can't get to the dev.example.com (or any other custom virtualhosts) here at work, which complicates other matters related to the sites on which I'm working...

  • Update: I get the (NXDOMAIN) error at home, too. However, I at lest can get an IP when I do a $host dev.example.com... it's the DNS server, but it's something! Commented Sep 28, 2010 at 15:11
  • Update 2: I added the OpenDNS servers to my computer at work, and now it's saying the same thing as the home computer for the host lookup... but still a no-go on loading the website. Commented Sep 28, 2010 at 15:33

1 Answer 1


Well, guess who's the village idiot? Me!

I decided to go back to the basics and see where I went wrong... turns out I had MAMP running on the MAMP default ports (8888 and 8889). Therefore, nothing worked when I went to dev.example.com on the default port (80).

Stupid waste of time. Oh well.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .