I'm running Windows 7 x64. Once in a while I have a process that freezes and that cannot be killed. I've tries the following:

  1. Process Explorer
  2. pskill
  3. taskkill /F /T

Nothing worked. Tools report that the process was killed successfully, but it just stays there.

How do I kill it?


I know now that it always happen when some application tries to connect to a SQL Server and the SQL Server is not started. The application always freezes.


As DougN assumed the number of handles of the frozen process was indeed 1. In the process explorer it showed this

Desktop \Default

Not sure what this is. I couldn't close this handle from Process Explorer. Then I searched for other processes that contained references to the frozen process. Found two handles in csrss.exe. Closed them. Then I tried to close the frozen process again, but it didn't work.

UPDATE I have tried the application called Advanced Process Termination v4.2. Which has 12+2+2 methods to kill stubborn processes. I've tried all the 16 methods and non of them worked. I believe that this is a Windows 7 bug.

UPDATE Seems that here's the discussion of this problem:


Look in Task Manager and add a column for Handles. If it has a very low number of handles (less than 10? Often 1) the process is dead and not running, but can't unload because something has a handle to it.

When it's happened to me, I had to find the process that launched it, and close the parent. Perhaps you could use Procexplorer and find the handle and manually release it though?

  • Thanks! I'll try that, but it's unlikely the reason, because last time the application was launched from Visual Studio and I closed it, but couldn't close the child process. – Max Oct 19 '10 at 23:27
  • In that case, also try killing mspdbsrv.exe (not sure if that will help, but seems related). – DougN Oct 19 '10 at 23:33
  • I have updated my question. Also I couldn't find mspdbsrv.exe in the process list – Max Oct 21 '10 at 21:16

I guess rebooting is not an option... If the process blocks the file access, you may try a tool like Unlocker which can release the lock of a file in most cases (and also killing the process). Maybe you could provide more information about the process which hangs. Maybe another guy already had the same problem.

  • I can close files from Proces Explorer also. Which I did. But this doesn't help. – Max Sep 29 '10 at 13:31
  • This happens to different processes. This time the process is a GUI application which uses SQL server. Nothing special. – Max Sep 29 '10 at 13:33

The only time a process can't be killed is when it is stuck in system/kernel call. Your comment that it happens to different processes suggest either hardware or driver problem.

Check disk for SMART errors, do a SMART test (using smartmontools), possibly a surface scan (using MHDD or HDTune). Do a memory check (using Memtest86+). Inspect system logs for errors/warnings.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.