I'm trying to mount a partition in solaris 10...

bash-3.00# mount /dev/dsk/c0t0d0s3 /data
mount: /dev/dsk/c0t0d0s3 is already mounted or /data is busy

As far as I know c0t0d0s3 isn't already mounted elsewhere, so what's really going on here?

From /etc/mnttab :

/dev/dsk/c1t0d0s0       /       ufs     rw,intr,largefiles,logging,xattr,onerror=panic,dev=7800001285811136
/devices        /devices        devfs   dev=4840000     1285811125
ctfs    /system/contract        ctfs    dev=48c0001     1285811125
proc    /proc   proc    dev=4880000     1285811125
mnttab  /etc/mnttab     mntfs   dev=4900001     1285811125
swap    /etc/svc/volatile       tmpfs   xattr,dev=4940001       1285811125
objfs   /system/object  objfs   dev=4980001     1285811125
sharefs /etc/dfs/sharetab       sharefs dev=49c0001     1285811125
/usr/lib/libc/libc_hwcap1.so.1  /lib/libc.so.1  lofs    dev=780000      1285811131
fd      /dev/fd fd      rw,dev=4b40001  1285811136
swap    /tmp    tmpfs   xattr,dev=4940002       1285811137
swap    /var/run        tmpfs   xattr,dev=4940003       1285811137
-hosts  /net    autofs  nosuid,indirect,ignore,nobrowse,dev=4c00001     1285811148
auto_home       /home   autofs  indirect,ignore,nobrowse,dev=4c00002    1285811148
cordb:vold(pid530) /vol    nfs     ignore,noquota,dev=4bc0001      1285811149

I suspect the problem is not related to the mount point, but rather the disk slice I'm trying to mount:

bash-3.00# newfs -v /dev/dsk/c0t0d0s3
/dev/rdsk/c0t0d0s3: Device busy
  • What's in /etc/mnttab? Sep 30, 2010 at 23:49

4 Answers 4


You could try using:

fuser -c /dev/dsk/c0t0d0s3

(or the rdsk equivalent) to see if there are any processes using that specific raw disk. Since this is Solaris 10, I have to ask does that partition contain any SVM or ZPOOL data that might be causing it to be used?

I know this was already basically suggested, but I didn't see the -c, so also try:

fuser -c /data

Try running fuser /data to see if any process has /data as its current directory or has a file open under that directory.

  • Nup, it's not the mount point:
    – Benco
    Oct 1, 2010 at 1:37
  • bash-3.00# fuser /data /data:
    – Benco
    Oct 1, 2010 at 1:37

There is some process whose current working directory is the /data directory. You could use the pwdx command on every running process.


I believe there is a "force" option to umount. Have you tried it? (It has been a while since I worked with Solaris.) I believe fuser also requires a command line option to work with a mount point. God help ya...but, you could unlink the device file and run mknod to recreate it....what about devfsadm...that used to work in Solaris 8. I think there is a new device manager...can't remember its name. I can't remember the whole use...but, IIRC, there was something about using luxadm to unmount a problematic disk. Yes, I know luxadm is/was for FC...but, something about it used to work with plain old SCSI.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.