2

HI,

Im trying to prevent vsftpd to start at boot time and didnt find how until now... Im using Ubuntu 10.04 LTS. I have installing vfstpd via apt-get I have removed the init script from init.d directory and did the following command :

update-rc.d vsftp remove
update-rc.d vsftpd remove

but vsftpd still run at boot time...

I would like to know how to prevent it to start at boot time and how to start it at boot time in case I change my mind.

thanks you all

0
4

Starting with Ubuntu 11.04 you can also use

echo manual >> /etc/init/vsftpd.override

Reference: https://askubuntu.com/a/20347

2

According to some search result on ubuntu forums the best way is to

mv /etc/init/vsftpd.conf /etc/init/vsftpd.conf.off
2
  • Starting with Ubuntu 11.04 you can also use echo manual >> /etc/init/vsftpd.override. Reference: [askubuntu.com/a/20347] – Stefan L Dec 16 '12 at 12:07
  • You should make that a new answer. When I posted my answer (2010) ubuntu (20)11.04 wasn't available yet. – ptman Dec 16 '12 at 13:34
1

I don't know why it's like this for you but personally I use

sysv-rc-conf

which is the visual editor that let you enable or disable your rc.d easily.

1
  • thanks but I have been using this one too and i think its doing quite the same job of update-rc.d and its doenst work too. vsftpd still launch at boot time. – Fabien Oct 5 '10 at 9:15
1

Look at the /etc/init/ scripts. Basically, if it's started via upstart, you just have to delete or comment the "start" statement on the top of the vsftpd related file.

1

Vstpd demon is controlled by new service: upstart.

You can turn off it by editing /etc/init/vsfpd.conf file and simple commenting 2 lines (in my case line 7 and 8). It should be something like that:

start on (filesystem
        and net-device-up IFACE!=lo)

Or you can use these command:

sudo sed -i.old -e '/start/,+1s/^/#/' /etc/init/vsftpd.conf

It comments the line with word start and the next line. Before changes it makes copy of the file and saves it under the name: vsftpd.conf.old.

0

Try looking for vsftpd references in /etc:

grep vsftpd -R /etc

It may be started from /etc/rc.local for example.

0

If there is not a listen=yes or listen_ipv6=yes in your /etc/vsftpd.conf, then the service will not be started.

0

with root permission

vim /etc/vsftpd.conf

set

listen=NO

then

service vsftpd restart
0

Try

sudo systemctl disable vsftpd.service

This will remove the symbolic link that indicated that the service should be started automatically. (Source: https://www.digitalocean.com/community/tutorials/how-to-use-systemctl-to-manage-systemd-services-and-units)

Works, if you use systemctl for autostart management.

How to find out, if you use systemctl:

  1. start your server ( vsftpd.conf start )
  2. if the line says [...] starten [...] (via systemctl), you have the answer
1
  • That's a lot of quoting to end up with a generic systemd answer. How about making it specific to vsftpd? – chicks Apr 8 '17 at 12:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy