I have an exchange 2010 server running on Windows 2008 R2, I also have a remote webserver running Windows 2003 with multiple sites on it (all asp.net mvc 2 sites). I setup a Transport in exchange and all the websites on my remote web server can send email no problem to anyone in the exchange server and to any external domain.

Now for my problem. I am having issues with that webserver, so I moved one of the websites to run on my exchange server, it runs well (low hit website) except that email doesn't work from that site. I tried changing the Transport in exchange to add the IP address of the local machine and the addresses and it still isn't sending any email.

Any ideas on how to get this working?

The remote websites can still send email no problem, the version of the site that I had to move on the remote server can still email, but on the exchange server for that website email does not send.

I would guess it is a Transport issue, since it is running on the same server a firewall shouldn't be the issue.

I changed the smtp setting in web.config to localhost, and now I do receive email to my account on the exchange server, but I do not receive any emails on outside addresses.

To add more description, this is a custom developed asp.net mvc 2 website. And no errors were being generated in the code when sending the email in either case.

  • When you say "Transport", are you referring to custom Receive connectors? – Mathias R. Jessen Feb 16 '12 at 7:26

You need to give more details about your application. Are you trying to send authenticated email or anonymous email? Are all your websites that were running on Windows 2003 no longer working with the exchange mail server or is it just one specific site?

You might want to check out http://www.systemwebmail.com/default.aspx as they may have a programmable solution for you. I don't recommend running any kind of website on an exchange server regardless of how heavy or light the usage may be.

Some simple things to check: firewall ports, any updates/patches applied to the exchange server and/or web server that may affect ports, check logs on both the web/exchange server, etc. etc. It would probably be easier to step-through your web application in visual studio using breakpoints to see what exactly is going on in the application, but I would try first to diagnose whether this is an application problem vs. non-application problem.

Is this a custom ASP.NET application or a vendor solution? I think you need to read this page (http://www.systemwebmail.com/faq/4.1.aspx#4.1) and try to determine some of the factors contributing to this issue.

| improve this answer | |

I would start by checking the logs of the receive connectors in Exchange. Usually in something like C:\Program Files\Exchange Server\V14\TransportRoles\Logs\ProtocolLog\SmtpReceive Make sure verbose logging is turned on for all the receive connectors.

  1. You can see if the application's emails are even making it to the point of connecting to the Exchange receive connector
  2. If you have multiple receive connectors you can check to see which is being used for the application's emails. I've had several instances where I have multiple receive connectors (one for internal emails from misc. network devices, one for receiving from internet, one for internal custom apps, etc.) and the wrong receive connector was receiving the email. I had different authorization (anonymous, authenticated, etc.) and allowed IPs for each, which was causing misc. issues. The fact that your site is on the Exchange server now may be causing it to use a different receive connector and be subject to something your app isn't accounting for.
| improve this answer | |

Do you have IPv6 enabled on the Exchange Server? When your website attempts to resolve the mail server name, it could be attempting to use the IPv6 address, which hasn't been mentioned in the above description of the receive connector.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.