7

I'm trying to set up rsync backups on my ReadyNAS and I'm getting the following error:

ERROR: The remote path must start with a module name not a /

This error is accompanied by the following information:

Job: 015
Protocol: rsync
Source: 192.168.140.25::/home/jason
Destination: [gob]/

I think the error makes sense because look what happens when I try this:

$ rsync -r 192.168.140.25::/home/jason dest/
ERROR: The remote path must start with a module name not a /

The command fails. If I change it only slightly, it succeeds:

$ rsync -r 192.168.140.25:/home/jason dest/

So the question is: Why is the ReadyNAS trying to run an rsync command with an extra colon? Is there something about the way rsync works that I don't understand?

2 Answers 2

4

When you run rsync HOST::PATH, rsync uses the rsync protocol (there must be an rsync daemon at the other end). When you run rsync HOST:PATH, rsync uses ssh (or rsh) for transport (there must be an ssh (or rsh) server and an rsync executable at the other end).

If ReadyNAS must use the rsync protocol, or if you prefer to use it, read the rsync manual for how to work and configure an rsync daemon. If you choose to use ssh transport, make sure to use a single :.

4

I just did this myself on my ReadyNAS and found that the module name is the name of the share.

So to transfer all my films to the Video directory under the media share I used:

rsync -rth --progress --stats --partial /home/data/Video/ user@192.168.1.129::media/Video

Obviously you need to enable rsync under the share settings (I enabled authentication also).

Using rsync like this instead of using SSH as well is much faster on these boxes as the overhead of encryption/decryption when using SSH has a massive effect on these relatively under-powered machines. Using rsync+ssh I was getting speeds of 6MB/s using plain rsync I get around 30MB/s (on a gigabit network).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.