On my domain i've got a w2k8 standard domain controller and a w2k8R2 domain controller.

I recently added dns to the w2k8R2 server in an attempt to set up a failover/secondary dns but it is not working when the primary dns goes down. It's somewhat difficult to schedule shutting down the primary machine to test the failover so I post this question today hoping to form the best plan of attack using some answers provided.

I've configured and checked quite a few things. I'll list what I think is important to hopefully cross off a few of the possibilities.

The w2k8 standard server holds all the FSMO roles and was the only dns until recently. Replication between domain controllers is working fine. Zone Aging/Scavenging has been set to 3 days on both dns servers. Only had to delete 3 or 4 very old entries that would not scavenge. Zone Transfers are allowed to other nameservers on this domain. Forward/Reverse zones on both dns servers have same records. Replication working between zones because the "old entries" I removed from the secondary dns replicated back to the primary dns.

I've tested with NSLookup and I get mixed results. I have a few random outputs of "Can't find x.x.x.xxx - non existent domain" when the given ip is definitely in the fwd/reverse zones of both dns servers. NSlookup out to the web works fine it seems. Tracert seems to be able to resolve happily along its hops.

One thing that worries me is that when I run ipconfig /all I only get the ipaddress of my primary dns server assigned to me. But, I can use nslookup interactive mode and use the "server x.x.x.x" command and switch dns server contexts. So nslookup seems to be aware of the fact that I have multiple dns's out there but i'm not handing out the ip as a secondary dns.

Can anyone suggest other things for me to check?


One thing that worries me is that when I run ipconfig /all I only get the ipaddress of my primary dns server assigned to me.

How are you assigning addresses to your clients? Have you updated DHCP to include the other DNS server? You need to manually update the configuration on any statically configured computer to include the IP of all the DNS servers that the client may use.

| improve this answer | |
  • The primary dns server also has dhcp role so it hands out ip's for 90% of the client workstations. I just went in an added my other dns under "server options" for the ipv4 section. I'll shut it all down tonight or tomorrow and test it again now that this piece of info has been added to dhcp. – TWood Oct 7 '10 at 21:01
  • Issue resolved. Might still have a reverse lookup issue or two but the failover works now. I just booted everyone off the server so I could test it out. Thanks Zoredache! – TWood Oct 7 '10 at 21:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.