A client of mine has an iPhone. We have verified that he has the correct settings input in his iPhone for his Exchange account. Other users have iPhones as well and are able to get email on their device. His username, password, server, email address, server are all correct. SSL is on which it should be. When setting up the account the iPhone accepts it but when he goes to check his mail a warning pops up stating that he is not able to connect to the Exchange server. Any ideas on where to look to solve this?

| improve this question | | | | |

Found the solution, at least for my case. In Active Directory went into the users properties, security tab, clicked on SELF, then advanced and checked the box to allow for inheritable permissions from the parent. After that he was able to sync up.

| improve this answer | | | | |
  • Thanks for coming back with the fix. I love the solutions which don't seem like they should've changed anything... – Kara Marfia Oct 10 '10 at 3:46
  • Yeah, I'm not sure how that setting was changed. Checked other users' accounts and that was checked. :-\ – Jason T. Oct 13 '10 at 14:52

Make sure that you're on Wifi and not the Cell networks.

Ensure that his Exchange server is reachable by the iPhone. Since you don't have a command-line to ping from, try accessing OWA (Outlook Web Access) by going to http://[mailserver]/exchange/

| improve this answer | | | | |

Have you tried setting his phone up with another user's account and setting his account up on another user's phone? This should tell you if it's a phone or account issue.

| improve this answer | | | | |
  • Well I tried setting his account up on my iPhone and the same thing happened. That's why I'm starting to think it's an issue with his account but I can't pinpoint it. – Jason T. Oct 8 '10 at 13:13
  • just get your exchange admin to compare accounts - tell him that you've tried what you just did ok, it'll help. – Chopper3 Oct 8 '10 at 13:22
  • In that case I'd look at the Exchange Features tab of the user account properties and make sure that Mobile Services are enabled. – joeqwerty Oct 8 '10 at 14:11
  • Thanks for the tip. Although after looking for that I cannot seem to find it. In fact, there is no Exchange Features tab for that user in AD. Nor does any other user have that tab. – Jason T. Oct 8 '10 at 14:53
  • just for sanity's sake try this problem user and a working user on another phone - just to be sure of your belief that it's a user issue ok. Also why not add a comment here showing the various config details (minus passwords of course) of the bad and good users - plus any other config details of the phones too - have you compared the data service APN settings etc.? – Chopper3 Oct 8 '10 at 14:57

It sounds like he opened his Exchange account somewhere before to me. Just check his PC to see if he already logged in first ... Or there is another case which is possible. That he has some diverse account all connecting to one single e-mail address, so when he logged in the system doesn't know where he referred to .

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.