Using gparted and partimage from SysRescCD I recently

  1. made a backup image of the partition containing my Ubuntu installation,
  2. deleted all partitions except for the original Windows partitions
  3. reduced the size of the Win7 partition
  4. created an extended partition using all unallocated space
  5. within the extended partition, created an ext3 partition and a swap partition
  6. restored the backup image to the ext3 partition

After these operations the ext3 partition is larger than when I started, but the filesystem is still reporting the old size:

$ fdisk -l 
Disk /dev/sda: 640.1 GB, 640135028736 bytes
255 heads, 63 sectors/track, 77825 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x1549f232

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1          13      102400    7  HPFS/NTFS
Partition 1 does not end on cylinder boundary.
/dev/sda2              13       12772   102487666    7  HPFS/NTFS
/dev/sda3           12773       76258   509947904    5  Extended
/dev/sda4           76258       77826    12591104    7  HPFS/NTFS
/dev/sda5           12773       25597   103010304   83  Linux
/dev/sda6           25597       27016    11395072   82  Linux swap / Solaris
/dev/sda7           27016       59024   257102848   83  Linux

The extended partition /dev/sda3 contains /dev/sda5, /dev/sda6/, and /dev/sda7. The Ubuntu image is on /dev/sda5 - which is the same partition it was originally on. Before the operations /dev/sda5 was 50GB, now it is 98GB.

$ sudo df -h
Filesystem            Size  Used Avail Use% Mounted on
/dev/sda5              50G   46G  2.3G  96% /
none                  2.9G  276K  2.9G   1% /dev
none                  3.0G  2.1M  3.0G   1% /dev/shm
none                  3.0G  372K  3.0G   1% /var/run
none                  3.0G     0  3.0G   0% /var/lock
none                   50G   46G  2.3G  96% /var/lib/ureadahead/debugfs
/dev/sdb1             597G  170G  427G  29% /media/My Book__
/dev/sda7             242G  8.2G  221G   4% /media/012583af-4e10-4bec-84b2-d691c3fd5f96

I'm looking for advice on what I can do to have ext3 on /dev/sda5 utilize the full 98G.

  • It's too late for that, but you could have enlarged the partition and filesystem together from GParted. Oct 10, 2010 at 7:17
  • Thanks - I tried GParted initially but IIRC had trouble using it since I couldn't create any more primary partitions and didn't see an obvious way in GParted to resolve that.
    – Brian Luft
    Oct 29, 2010 at 2:03

2 Answers 2


What you're attempting to do is resize the filesystem. Your image based backup kept all of the metadata that was on the original partition, which as you noticed also included the size. The program for this is resize2fs. You've already done the heavy lifting of getting the partition enlarged, so it should go pretty fast. Since it is your root partition, this will have to be done from single-user mode (or possibly booted from an ISO-Linux of some kind, I'm not certain).

resize2fs /dev/sda5

That should be all you need to do.

  • resize2fs can even enlarge a mounted ext3 filesystem, so you can boot normally and run the command. Oct 10, 2010 at 7:16
  • Apologies for the delay. Thanks sysadmin1138 and Gilles for the advice. Worked while mounted, as advertised :)
    – Brian Luft
    Oct 29, 2010 at 2:01

The fact is when you copy back a backup of the partition it keep (as you notice) the size it was because the filesystem has some field for that. What I suggest you is not to copy the entire partition, but reformat in ext3 your partiton of 98G and copy the files into that new partion. To avoid some permission problem use the command cp -pr (p flag for permission keep and r for recursive)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.