I've setup a Citadel groupware server, plus its WebCit web admin interface. It worked well with HTTPS access. However, I had to reinstall the server, and when I try to access the server again via HTTPS, I get the following error in Firefox:

You have received an invalid certificate. Please contact the server administrator or email correspondent and give them the following information:

Your certificate contains the same serial number as another certificate issued by the certificate authority. Please get a new certificate containing a unique serial number.

(Error code: sec_error_reused_issuer_and_serial)

What can I do on the server side to alleviate this problem? Or is it simply a matter of resetting something in Firefox?? What would be a way to prevent this problem in the first place? Thanks.


I've seen this error before while using FireFox with a WiFi router - it's annoying, because FF does not behave as you'd expect (i.e. let you add an exception and be done with it).

Granted, the problem is with your SSL certificate (it should have a new serial number when it is generated) but because the cert is generated with a hard-coded value it is going to be easier to apply a workaround for FireFox.

Here's the fix that worked for me:

Thinking "How does it know?" I thought it must be storing the certificate elsewhere. I shut down Firefox, opened my profile directory, found cert8.db, renamed it and started Firefox. The cert8.db file was recreated and I was able to add the exception for the new certificate.

Same Serial Number of Certificate Error at FireFox Support


Quick dirty fix

You can solve it very fast by erasing cert9.db, cert_override.txt but you lose your certs.

Good fix

Follow https://support.mozilla.org/en-US/kb/Certificate-contains-the-same-serial-number-as-another-certificate.

NOTE: In my case I was not able to find the item at Authorities in step 9 and I had to:

  1. Find the certificate with certutil -d sql:/path/to/firefox/certs -L.
  2. Remove the certificate with certutil -d sql:/path/to/firefox/certs -D -n cert_name.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.