Got an odd problem which has me stumped.

We're trying to add a windows 2008 R2 server to an existing forest. What we have is something like this:

  • mydomain.com
  • Paris.mydomain.com
  • Newyork.mydomain.com

which are all running win 2003 R2.

I want to add another domain, like madrid.mydomain.com, but using win 2008 R2. The DVD is spanish language but we've mui'd the install so it appears in english for the moment.

I've adprepped (forest and domain) the dc's on the root mydomain.com using the adprep which comes on the 2008 R2 dvd. (this is a dvd - I've seen a lot of references to using adprep from the second cd - there's only one)

The first oddity I saw was that Adprep doesn't display any initial text when executed on the existing win2003r2 DC for mydomain.com. If you press 'c', it proceeds to apply the AD modifications. I'd guess this has something to do with adprep being an mui spanish version copied across to an english language server... but odd never the less.

It applied the changes as is usual and using ldap I can see that the AD version is 47 - correct for 2008 R2.

However when I attempt to join the domain it still says I have to execute forestprep.

If I execute adprep/domainprep it does nothing - really nothing, it opens and closes and I get command prompt back. When I execute Adprep /forestprep it displays about 3 lines of dots each time I execute it, but no text messages.

Nothing changes in the ldap object version

SO.... in the absence of any other ideas, I tried using a copy of win2003 R2 temporarily as my DC for madrid. No problems it comes up and I now have a subdomain but using a temp server.

I get the same behaviour with this new win2003DC as I did with the other mydomain.com one:

  • adprep doesn't display text when you type 'adprep /?'
  • adprep /domainprep doesn't result in any messages
  • adprep /forestprep displays about 3 lines of dots each time I execute it but no messages.

Servers have been rebooted - no effect. Functional level of AD is 2003. DNS is ok with all the usual structures for AD. netdiag, dcdiag, dnslint all return normal results.

Right now I'm lost for ideas. Any suggestions?


  • 2
    On the schema master, run repadmin /syncall, wait a minute or ten, run repadmin /showrepl and see if it's all good. – Chris S Oct 11 '10 at 16:00
  • Chris beat me to it. This sounds replication fishy to me – Jim B Oct 11 '10 at 16:04
  • Are you running forest prep on the schema master? Are you running domainprep on the infrastructure master? Are you running the command as adprep /domainprep /gpprep? Check this page out - technet.microsoft.com/en-us/library/cc731728(WS.10).aspx. – Christopher Oct 11 '10 at 21:01
  • My first reaction was a replication issue. Its a new domain but I didn't build it. I've just gotten involved because of this and other problems. There were indeed replication issues, which I resolved before doing this. This is being done on a dc which is the master for all roles (because temporarily its the only dc in the mydomain.com domain - yeah I know another problem) – Ian Murphy Oct 12 '10 at 7:01

I know, this thread is old but, can be usefull for some one.

Hello sysadmin1138 I found the cause of the lack of messages, the image of windows used to run the adprep, is in a different language of the destine windows.

To resolve this I just had to change the name of the folder that contained the message files in the folder of adprep.

In my case I rename of "pt-pt" to "pt-br" and it worked!!

  • Good to know. Now I just have to remember to try this the next time it occurs. Thanks – Ian Murphy Jul 13 '12 at 16:01
  • Thank you very much! I was in similar situation. I've tried to adprep domain on english W2003 with adprep from czech W2008R2 DVD. Simple renaming of directory cs-cz to en-us didn't help, I had to find english DVD and use adprep from there. Fudging MS with their localization... You sir deserve more than one upvote. – mkudlacek Oct 24 '13 at 17:57

Well, I think I found the cause. I hadn't raised the functional level of the domains or the forests before starting - which I didn't notice because the spanish copy of adprep didn't display any messages on the English language win2003 dc.

Last night I downloaded the english Win 2008 r2 eval iso from MS and used the adprep from there and guess what........ This is what it displayed this morning when I tried to adprep the domain

c:\adprep>adprep /domainprep Running domainprep ...

Adprep detected that the domain is not in native mode [Status/Consequence] Adprep has stopped without making changes. [User Action] Configure the domain to run in native mode and re-run domainprep

obvious once you see the message.

Anyone know a way of opening a bug report with MS without paying to open a call?


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.