I need to reload my php.ini and there's nothing in the help dialog about restarting it.

18 Answers 18


Note: prepend sudo if not root

  • Using SysV Init scripts directly:

    /etc/init.d/php-fpm restart    # typical
    /etc/init.d/php5-fpm restart   # debian-style
    /etc/init.d/php7.0-fpm restart # debian-style PHP 7
  • Using service wrapper script

    service php-fpm restart    # typical
    service php5-fpm restart   # debian-style
    service php7.0-fpm restart # debian-style PHP 7
  • Using Upstart (e.g. ubuntu):

    restart php7.0-fpm         # typical (ubuntu is debian-based) PHP 7
    restart php5-fpm           # typical (ubuntu is debian-based)
    restart php-fpm            # uncommon
  • Using systemd (newer servers):

    systemctl restart php-fpm.service    # typical
    systemctl restart php5-fpm.service   # uncommon
    systemctl restart php7.0-fpm.service # uncommon PHP 7

Or whatever the equivalent is on your system.

  • 2
    What about on a Mac? php-fpm was installed using homebrew. which php-fpm gives /usr/local/sbin/php-fpm.
    – hobbes3
    Commented Mar 16, 2013 at 23:06
  • 6
    @hobbes3 try brew services restart php56 (if you get an error about no available formula, try a different version e.g. php5 or php55). If you don't have brew services installed, it should install it for you on the first run.
    – Doktor J
    Commented Dec 21, 2015 at 22:22
  • None of the above worked for me, but this did: service php-fcgi-mydomain-com restart And I had to repeat it for every domain from sites-enabled
    – Ilyich
    Commented Mar 12, 2018 at 19:01
  • This one was the good one for me (centOs) : systemctl reload php70-php-fpm
    – 4wk_
    Commented Jul 25, 2018 at 12:58
  • I'm on Ubuntu 16.04 and this seemed to work: systemctl restart php5.6-fpm.service
    – relipse
    Commented Dec 7, 2018 at 19:36

For Mac OS X, this is what I do:

Make a script /usr/local/etc/php/fpm-restart:


echo "Stopping php-fpm..."
launchctl unload -w ~/Library/LaunchAgents/homebrew-php*.plist

echo "Starting php-fpm..."
launchctl load -w ~/Library/LaunchAgents/homebrew-php*.plist

echo "php-fpm restarted"
exit 0


chmod ug+x /usr/local/etc/php/fpm-restart
cd /usr/local/sbin
ln -s /usr/local/etc/php/fpm-restart

make sure /usr/local/sbin is in your $PATH

then just call it from the terminal fpm-restart and BOOM!!


Usually, service php5-fpm restart will do fine, on an up-to-date distribution.

But somtimes, it fails, telling you restart: Unknown instance: (or such).

Now, if you do not like to reboot your server, just kill the processes and have a fresh start (edited as of here):

$ sudo pkill php5-fpm; sudo service php5-fpm start
  • Thanks, this fixed exactly my issue. (stop: Unknown instance:)
    – Nilloc
    Commented Aug 31, 2016 at 15:00

This should work:

pkill -o -USR2 php-fpm
pkill -o -USR2 php5-fpm
  • 3
    If you installed PHP-FPM via homebrew on a Mac, the first command works a lot better than unload+load'ing the plist
    – Alan Ivey
    Commented Jul 19, 2013 at 21:01
  • OSX: killall php-fpm
    – ptim
    Commented Aug 22, 2014 at 14:28
  • On OSX the above gave me an error "Unknown user SR2". Reversing the arguments fixed it: "pkill -USR2 -o php-fpm"
    – Keeth
    Commented Jan 9, 2015 at 11:44
  • Exactly what I needed to restart FPM in a container, thanks! Commented Oct 27, 2015 at 0:32
  • I am using the pre-installed, or bundled with xcode, version of php and its associated -fpm for some reason, and not through Homebrew. Just thought I should use what's there already. I am using a combination of php-fpm --prefix /usr/local, making some directories under that one it needs, and as @Keeth has stated, pkill -USR2 -o php-fpm, checking with pgrep -l fpm, and the PIDs do indeed change! I had no plist files or services to take advantage of mentioned by some of the other answers.
    – Pysis
    Commented Aug 10, 2017 at 3:41

For Mac OSX brew services restart php56 worked for me.

  • 1
    yup, works for me also. Mac osx Commented May 24, 2017 at 5:15

I had a problem restarting php7-fpm, because I didn't knew how exactly the service was named. This function gave me the answer:

service --status-all

php7-fpm service in my Ubuntu was called php7.0-fpm, so I did:

service php7.0-fpm restart

  • 5
    +1 for service --status-all
    – J.D.
    Commented Dec 13, 2017 at 23:33

php-fpm will restart if you send a USR2 signal to the main process:

sudo kill -USR2 php-fpm_main_process_id

So we just need to instruct php-fpm to record its pid somewhere. In this example, I'll assume you want to save it at /etc/private/php-fpm.pid, and that php-fpm runs as user _php. First, add this line to the configuration file:

pid = /etc/php-fpm.pid

Then create the file /etc/php-fpm.pid, and make sure php-fpm has permission to modify it:

$ cd /etc
$ sudo touch php-fpm.pid
$ sudo chown _php php-fpm.pid
$ sudo chmod 644 php-fpm.pid

Now, next time php-fpm starts, you'll be able to get its pid and restart it like this:

$ cat /etc/php-fpm.pid
$ sudo kill -USR2 815

Or you can combine these into a single command:

$ sudo kill -USR2 `cat /etc/private/php-fpm.pid`
  • I am liking @dialt0ne's and @Keeth's pkill ... answer & comment above more; shorter and simpler.
    – Pysis
    Commented Aug 10, 2017 at 3:43
  • this is better, and nice explanation. the pkill runs the risk, if you don't get the processes matched correctly, of killing off your other PHP clusters if you happen to have them running on the same box (yes this is bad practice).
    – Richard
    Commented Oct 30, 2017 at 16:47

For me I had just upgraded via apt and the service restart wasn't working. I ended up needing to kill the existing processes before it worked using: killall php5-fpm


To allow the PHP-FPM restart script to work, you must use specify a PID file in your php-fpm.conf file. i.e.

pid = /var/run/php-fpm/php-fpm.pid

The default value for pid in php-fpm.conf is nothing, which means to not create a PID file, which means that the restart script can't tell which process to end during the restart.


On CentOS 7

sudo systemctl enable php-fpm // Just incase is disabled. Also ensures it starts automatically with the server

sudo systemctl start php-fpm  // Start the service

sudo systemctl stop php-fpm   // Stop the service

sudo systemctl status php-fpm  // View status

On Ubuntu 16 with php 5.6 fpm.

 /etc/init.d/php5.6-fpm restart

On RedHat / CentOS 7 using PHP 7 from softwarecollections.org

service rh-php70-php-fpm start
service rh-php70-php-fpm stop
service rh-php70-php-fpm reload
service rh-php70-php-fpm restart
service rh-php70-php-fpm status

or if you're using systemctl:

systemctl start rh-php70-php-fpm
systemctl stop rh-php70-php-fpm
systemctl reload rh-php70-php-fpm
systemctl restart rh-php70-php-fpm
systemctl status rh-php70-php-fpm

The simplest way to find the name of php-fpm service is to search for it:

systemctl -l --type service --all | grep fpm
  • 2
    You can make it simpler: systemctl list-units *fpm* Commented Mar 17, 2019 at 16:40

On Windows:

  1. Open Services in the Management Console:

    Start -> Run -> "services.msc" -> OK
  2. Select php-fpm from the list

  3. Rightclick and select restart

For old versions of debian & ubuntu - php 5.6 it will be

 /etc/init.d/php-fpm56 restart
 service php-fpm56 restart

On Alpine with nginx this is working here:

To kill all php-fpm7 processes:

kill $(ps -o pid,comm | grep php-fpm7 | awk '{print $1}')

To start php-fpm7:



To list systemd services on CentOS/RHEL 7.x+ use


To list all services:

systemctl list-unit-files

Where you can find service named * php-fpm * copy service name and run the following command

systemctl restart ea-php72-php-fpm.service

NOTE : ea-php72-php-fpm.service user your service name


Another method for MaxOS

Open ActivityMonitor, search php-fpm, find the pid.

Open terminal, use kill [pid] to stop php-fpm

Then php-fpm on terminal to start it.

If there is error information that Already in use, just ignore that.

Refresh Nginx page, should see php.ini changes take effects.

  • What is MaxOS? Just running php-fpm will most probably run it under the wrong user; ignoring error messages is never a good idea. Commented Sep 23, 2019 at 8:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .