1

I am running Windows7 RC1, I have recently installed CheckPoint VPN SecureClient (http://www.checkpoint.com/products/vpn-1_clients/) to connect to my work network. On installation this appears to have disabled Fast User Switching.

Switch user disabled

You will notice "Switch user" is now greyed out. I tried some googleing first and the most popular solution is to remove a registry entry at HKEY_LOCAL_MACHINE \ SOFTWARE \ Microsoft \ Windows NT \ CurrentVersion \ Winlogon \ GinaDLL

I have no entry there.

Any ideas? Thanks.

1
3

It is disabled on purpose by CheckPoint, we use that here as well. It is in their documentation as a "known limitation".

You can re-enabled it using a registry edit, but I do not know if I can recommend doing that.

Search for the registry key "HideFastUserSwitching" if you want to test it out.

1
  • 1
    Full registry key is Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System\HideFastUserSwitching. Thanks for that worked a treat. Jun 3 '09 at 19:11
0

I had the same issue after installing and later uninstalling Checkpoint SecureClient. Open REGEDIT and do a find for the registry key "HideFastUserSwitching". Once found the value should already be set to "1". You need to change this value to "0", exit REGEDIT and reboot. Once you have rebooted fast user switching should be available again.

0

After "unhiding Fast user switching" on windows 10 Pro, I still had an error message telling that due to policy, only one user could be connected to this computer at a time.

I had to run Services.msc and disable "Network Access Management Logon Module".

Though, disbling this service will make some NAM's functions unavailable.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.