For the NAS sharepoints and NAS storage, is it possible someone can run a scan and tell if there are any .exe or .bat files on the NAS systems? (EMC CELERRA)

The customer mentioned to me today that he was concerned his environment had executables on the NAS that might not run across the network when the NAS data is migrated to a different location.

Can somebody explain me how the executables can cause barrier ?? And how do I run a scan for the .exe or .bat files.? @LAin-nasadmin@memsrv280 ~]$ find /root/of/filesystem/to/scan ( -name '.exe' -o -name '.bat' ) find: /root/of/filesystem/to/scan: Permission denied is not letting me run the scan on celerra control station which is unix based. However, / -name '*.exe' lets me.

Does the client's concern about how executables is going to effect when NAS data is migrated to a different location make any sense?

This is the out put i got, all i believe 're from nas root files- find: /proc/31398/task: No such file or directory 181643 24 -rw-r--r-- 1 root root 23040 Apr 8 2010 /usr/lib/syslinux/syslinux.exe 232333 60 -rwxr-xr-x 1 root root 57344 Apr 7 2006 /usr/lib/python2.3/distutils/command/wininst.exe 46086 48956 -rwxr-xr-x 1 root root 50076197 Sep 26 03:42 /home/nasadmin/nas56493.exe 46100 48964 -rw-r--r-- 1 root root 50084600 Aug 27 14:34 /home/nasadmin/nas5649301.exe 66229 60 -rw-rw-r-- 1 root root 57344 Apr 7 2010 /nas/http/webui/tools/tomcat/bin/tomcat4.exe 66230 100 -rw-rw-r-- 1 root root 98304 Apr 7 2010 /nas/http/webui/tools/tomcat/bin/tomcat4w.exe 41742 76 -rwxrwxr-x 1 root nasadmin 76265 Sep 25 23:57 /nbsnas/dos/bin/dartload.exe 41743 92 -rwxrwxr-x 1 root nasadmin 93062 Sep 25 23:57 /nbsnas/dos/bin/flashupg.exe 41744 76 -rwxrwxr-x 1 root nasadmin 76073 Sep 25 23:57 /nbsnas/dos/bin/gload.exe 41745 32 -rwxrwxr-x 1 root nasadmin 32225 Sep 25 23:57 /nbsnas/dos/bin/loadlin.exe 41746 48912 -rwxrwxr-x 1 root nasadmin 50084600 Sep 26 03:42 /nbsnas/dos/bin/nas.exe 41747 4 -rwxrwxr-x 1 root nasadmin 3339 Sep 25 23:57 /nbsnas/dos/bin/reboot.exe 41748 8 -rwxrwxr-x 1 root nasadmin 7839 Sep 25 23:57 /nbsnas/dos/bin/restcmos.exe 41749 376 -rwxrwxr-x 1 root nasadmin 383240 Sep 25 23:57 /nbsnas/dos/bin/sibpost.exe 41750 352 -rwxrwxr-x 1 root nasadmin 357800 Sep 25 23:57 /nbsnas/dos/bin/t2slot.exe 41751 20 -rwxrwxr-x 1 root nasadmin 17305 Sep 25 23:57 /nbsnas/dos/bin/ver_chk.exe 41762 432 -rwxrwxr-x 1 root nasadmin 441436 Sep 25 23:57 /nbsnas/dos/emulex/lp6dutil.exe 41763 16 -rwxrwxr-x 1 root nasadmin 12393 Sep 25 23:57 /nbsnas/dos/emulex/lpscript.exe 200527 48956 -rwxr-xr-x 1 root root 50076197 Apr 8 2010 /nbsnas/dosfs/bin/nas.exe 201415 80 -rw-rw-r-- 1 root root 76265 Apr 8 2010 /nbsnas/dosfs/bin/dartload.exe 201351 96 -rw-rw-r-- 1 root root 93062 Apr 8 2010 /nbsnas/dosfs/bin/flashupg.exe 200517 80 -rw-rw-r-- 1 root root 76073 Apr 8 2010 /nbsnas/dosfs/bin/gload.exe 200523 32 -rw-rw-r-- 1 root root 32225 Apr 8 2010 /nbsnas/dosfs/bin/loadlin.exe 200524 4 -rw-rw-r-- 1 root root 3339 Apr 8 2010 /nbsnas/dosfs/bin/reboot.exe 200617 8 -rw-rw-r-- 1 root root 7839 Apr 8 2010 /nbsnas/dosfs/bin/restcmos.exe 200514 380 -rw-rw-r-- 1 root root 383240 Apr 8 2010 /nbsnas/dosfs/bin/sibpost.exe 200516 356 -rw-rw-r-- 1 root root 357800 Apr 8 2010 /nbsnas/dosfs/bin/t2slot.exe 200521 20 -rw-rw-r-- 1 root root 17305 Apr 8 2010 /nbsnas/dosfs/bin/ver_chk.exe 61784 60 -rw-rw-r-- 1 root root 57344 Apr 7 2010 /nbsnas/http/webui/tools/tomcat/bin/tomcat4.exe 61787 100 -rw-rw-r-- 1 root root 98304 Apr 7 2010 /nbsnas/http/webui/tools/tomcat/bin/tomcat4w.exe

  • 1
    That looks to me like you have run the find command on the operating system of the NAS box rather than the filestors. – user9517 Oct 14 '10 at 11:49

Well, I guess you can't run the .exe or .bat files on a none compatible system. So, you'd not be able to natively run from the Linux, for example. The type of storage these file types are stored on is largely irrelevant, so I'm not sure why that seems to be coming into the equation. Possibly, the whole storage area will be moved from shared storage onto none-shared storage, so access will no longer be available? That's all I can think of at the moment.

As for finding the files, I'm not sure of any EMC tools that will do this. However, a simple dir *.exe /s from the root of your storage should find them your exe files, and obviously dir *.bat /s for the batch files (Assuming the root of your storage is mapped to a drive on a Windows machine)

You may also consider using a tool like TreeSize as that will interrogate the volume, and break the data down in all kinds of ways that may, or may not, be of use to you

  • Ben , Thnaks for your response- I tried using the command from root of Control station-================================[nasadmin@memsrv280 ~]$ su Password: [root@memsrv280 nasadmin]# dir *.exe /s dir: /s: No such file or directory nas5649301.exe nas56493.exe [root@memsrv280 nasadmin]# dir *.bat /s dir: *.bat: No such file or directory dir: /s: No such file or directory ========================================= – wildchild Oct 14 '10 at 8:25
  • 1
    Sorry, I wasn't clear. This should have been from a Windows host. I'm not sure if this is available at the console of your storage platform, but maybe try: find / -name '*.exe' -ls – Ben Quick Oct 14 '10 at 8:59
  • I'm not sure of the layout of your NAS, never used a Celerra. From your updated question, it looks like you want to substitute the bare '/' for whatever is classed as the root for your file shares. E.G. 'find /usr/shares -name '*.exe' -ls' or whatever the correct path is for your deployment. I may be able to work it out if you do an 'ls -l /' and post the result – Ben Quick Oct 14 '10 at 12:10
  • 1
    Check out the screenshots to see what kind of breakdowns are available: jam-software.com/treesize/screenshots.shtml – Ben Quick Nov 4 '10 at 10:34
  • 1
    I believe TreeSize needs shares to scan or drive letters, not just the high-level \\servername\ I'm sure you could script something if you really have that many to scan, though – Ben Quick Nov 11 '10 at 10:46

Presumably your customer is concerned that if this machine is moved their firewalls will block whatever NAS protocols your Celerra is sharing with, therefore they won't be able to mount the shares and use the executable - it's the only reason I can think why they'd ask. If they're just very confused they might think that the executable just won't work, which it should of course, perhaps more slowly but it should just work if they can mount the same share in the same way.

  • I've meet more than a few people who think that programs will run differently on their local computer because of where the file is stored on the SAN/NAS/Server/etc. Careful not to overestimate managers' knowledge of networking or modern operating system... – Chris S Oct 14 '10 at 12:34

If your using a unix like system then the find command is what you want

find /root/of/filesystem/to/scan  -name '*.exe'
find /root/of/filesystem/to/scan -name '*.bat' 

will do a scan for you.

if you want to find more than one file type in a single command then

find /root/of/filesystem/to/scan  \( -name '*.exe' -o -name '*.bat' \)

works too. You may not need the \( and \) but it doesn't hurt if they are there.

  • somebody voted me down , don't know for what reason. Any way,i 've sent the scanned result to the customer. Moreover, i deleted the unwanted post .I thank all of you again for helping me understand the things i was looking for. – wildchild Oct 17 '10 at 5:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.