10

I've been tasked with setting up an FTP directory for a client of ours. I'm working from a Windows 2008 Server with IIS 7 installed.

To create the FTP user directory I've followed this eHow tutorial.

The FTP site is already set up on IIS 7, so I skipped that bit and followed the rest exactly. However, when I try to connect via FileZilla, I get the following errors:

Status: Connecting to xxx.xx.xx.xx:21...
Status: Connection established, waiting for welcome message...
Response: 220 Microsoft FTP Service
Command: USER userFTP
Response: 331 Password required for userFTP.
Command: PASS ********
Response: 530 User cannot log in, home directory inaccessible.
Error: Critical error
Error: Could not connect to server

I've double checked the permissions of the user and everything appears to be as it should. If anyone has any advice, I'd be so grateful.

5

It's not clear to me from reading your post and the link you provided as to whether or not you're using user isolation. My suggestion would be to determine whether or not you want to use user isolation or not and then start from scratch.

Here's a link that may help:

http://learn.iis.net/page.aspx/305/configuring-ftp-75-user-isolation/

  • Hi, User isolation is in place. I'm taking over the management of the server (despite a complete lack of server experience!) from the guy who originally set it up. – 109221793 Oct 14 '10 at 13:19
  • In the end I gave up and started from scratch. I appeared to do the exact same thing I was doing before but for some reason this time it worked! Thanks for your help. – 109221793 Oct 14 '10 at 15:07
  • Glad to help... – joeqwerty Oct 14 '10 at 15:14
4

It is the user isolation setting.

You will need change it to "do not isolate users, start users in "user name directory" "

4

I just hit this issue and for anyone googling the error would like to add the solution that worked on Windows Server 2012 IIS 8.0. It was very simple in the end you have to create a LocalUser folder in the FTP root you specified when creating the FTP site. Then create your username folders under this folder.

For e.g. D:\ftp-root\LocalUser\user1

1

Another cause of this error can be the use of FTP IPv4 Address and Domain Restrictions.

If your IIS FTP Site, or one of its parents including the Default site, is using IPv4 Address Restrictions then you'll need to ensure that your IP address is allowed.

I had this same issue you've described, with the exact same Error returned to FileZilla. Here's how I fixed it:

  1. Open the IIS Manager
  2. Click on the Sites > Default FTP Site settings
  3. Open FTP IPv4 Address and Domain Restrictions
  4. Ask Google what is my ip
  5. Add your public IP address to the allowed list under FTP IPv4 Address and Domain Restrictions
  6. Open Services from the Start Menu
  7. Find the Microsoft FTP Service in the Started Services list
  8. Restart the Microsoft FTP Service

IIS Manager FTP IPv4 Address and Domain Restrictions

0

Check the FTP logs recorded by IIS. The status and sub-status codes will give you more information about the issue. Here is a list of the status codes: The FTP status codes in IIS 7.0 and later versions

In my case, this issue occured because my IIS wasn't configured for passive mode. After entering a port range and external IP address in FTP Firewall Support feature, the error message disappeared:

enter image description here

In this blog post, it mentions a few more root causes: 530 User cannot log in, home directory inaccessible

Authorization rules. Make sure to have an Authorization rule that allows the user or anonymous access. Check “IIS > FTP site > FTP Authorization Rules” page to allow or deny access for certain or all users.

NTFS permissions. The FTP users (local or domain users) should have permissions on the physical folder. Right click the folder and go to Properties. In the Security tab, make sure the user has required permissions. You can ignore Shared tab. It is not used for FTP access.

Locked account. If you local or domain account is locked or expired, you may end up seeing “User cannot log in” error. Check local user properties or Active Directory user settings to make sure the user account is active.

Other permission issues. The user account may not have “Log on locally” or “Allow only anonymous connections security” rights.

-1

I know you said you double checked the permissions, but I wanted to verify that you'd checked the file- level permissions as well as the share permissions?

  • I've double checked those also. Seem fine. – 109221793 Oct 14 '10 at 12:18
-1

You will need to verify the Physical Path of the FTP. Following is the steps to check.

Go to IIS.

Right, Click on Default FTP site. Manage FTP Sit >> Advance

Settings >> Physical Path.

It must be correct or you will find home directory inaccessible.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.