2

I am following the instructions http://sporkcode.wordpress.com/2009/07/11/installing-the-haskell-platform-in-ubuntu/ for installing GHC in Ubuntu. And I want install it in my home directory. I have successfully installed GHC, but when I try to install the Haskell platform, the configure script complains that GHC doesn't work. This is because ld cannot find the GMP library, which is installed in ~/lib and GHC does not appear to pass LDPATH or LD_LIBRARY_PATH to ld. Suggestions?

1

You can issue an argument to ./configure of haskell-platform

Optional Packages:
  --with-PACKAGE[=ARG]    use PACKAGE [ARG=yes]
  --without-PACKAGE       do not use PACKAGE (same as --with-PACKAGE=no)
  --with-ghc=ARG          Use ARG as the path to ghc [default=autodetect]
  --with-ghc-pkg=ARG      Use ARG as the path to ghc-pkg [default=autodetect]
  --with-hsc2hs=ARG       Use ARG as the path to hsc2hs [default=autodetect]

Could one of these be what you are looking for? To see all the available options do

./configure --help
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.