0

I'm trying to install RedMine (www.redmine.org) which is an awesome project management tool. I have access to a CentOS machine which is supposed to host it. I found some guide specifying how to install an old version of ruby and I tried to install it and then update to no avail. The latest version of rails requires a newer version of ruby than what I've got installed.

Could someone point me in the direction of how I can upgrade that ruby version? Yum hasn't registered it so I'm kind of stuck..

1

a good starting point may be the slicehost articles on ruby on centos, but if your looking for the latest and greatest in terms of the newest version you will havre to compile from source or find a repo which you trust etc. just from a quick google something along the lines of this will work but like i said you need to a:) trust the repository and b:)be aware that you are deviating from the stable branch of the OS etc.

  • Thanks, I solved it after a lot of fighting and a little learning. Your proposed links would have helped me and any other peer stumbling upon the same problem so I marked as answer. – Phil Oct 18 '10 at 17:14
  • Phil your welcome, ruby's not really my think it was more of a nudge in the right direction kind of thing............. – seanl Oct 18 '10 at 21:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.