UPDATE: I think the real question I need to ask here is: how does a technician debug UI problems with Internet Explorer, and not HTML rendering issues that have pretty good tools? I am aware of the SysInternals tools and others mentioned below, but maybe I am not harnessing their power properly. Someone else in the TechNet forum I mentioned had a similar issue. Again, I have lots of data, I am not sure how to properly interpret it.

ORIGINAL POST: So I tried the venerable Technet Forums to solve this isse. In short, the Windows Security dialog has no place to put credentials, rendering pretty much useless. This happens to apply for a whole bunch of our intranet websites, and only a select number of users with a few laptops have this problem. It ends up looking like this.

alt text

Things I have tried so far:

  • Disabling local Group Policy (not domain connected)
  • Disabling local Security Policy
  • Resetting IE settings
  • A few system restores
  • Re-registering a bunch of IE DLL's and all other steps here
  • Reinstalling IE8 (dism /online /disable-feature /featurename:"internet-explorer-optional-x86, reboot, dism /online /enable-feature /featurename:"internet-explorer-optional-x86, and reboot)
  • And SFC scan, which found nothing

Still, nothing. Not only am I fed up, but I have begun to really work with APIExplorer and Procmon as mentioned in the Technet original because I want to know WHAT is happening, not just fix it. Any thoughts?

  • So again, crickets? Are my questions that bizarre? – songei2f Oct 20 '10 at 8:26
  • 2
    You may try re-wording your question to an actual question, such as "Why does my intranet site display a login dialog without any fields to enter credentials?" It offers more information on your problem which should get more people familiar with these situations to actually read the post. You will also want to provide more information. All that we have so far is that there are Windows 7 client laptops that are not on a domain that get authentication prompts without anywhere to put their credentials. What about the web server hosting the sites? – Cypher Nov 24 '10 at 4:53
  • Lastly, if you update your question with more information as you find it, your question will jump to the top of the questions list giving others the opportunity to read your question's updates. – Cypher Nov 24 '10 at 4:54
  • @Cypher I realize all your points are valid, but there is not much additional information I could give. I am going to reformulate the question, I suppose. – songei2f Nov 28 '10 at 16:39
  • Is it isolated to user profiles or machines? Ie if a user without the problem uses a "troubled" machine, does he/she get the problem or not? And what about vice versa? It sounds like a faulty installation - does a wipe and reload of the machines solve the problem? – Oskar Duveborn Nov 28 '10 at 18:15

Have you tried adding the app URL to the Local Intranet Zone? The screenshot shows it in the Internet zone which will be very restricted by default, especially in IE8. Nowadays it is the browser security features causing a large number of such issues.

I would also recommend enabling script debugging in Internet Options. Then when an error is encountered, review and research the details of the error. That is my bread and butter for this type of issue.

Another thing is to verify the security setting User Authentication in whatever zone you are using. You may want to set it to Prompt for User Name and Password.

And in the Internet options > Advanced tab, try enabling Integrated Windows Authentication on the problematic browsers.

  • Thanks for the tips. I am fairly certain I tried all of these. I retried all of them on one problematic machine; no solution, and I recreated the error every time. Some DLL or important file must be damaged, but it is still unclear what. – songei2f Dec 2 '10 at 11:49
  • Have you tried another browser or HTTP client like WGET? Watching the HTTP traffic may reveal the issue. Something like Firebug of Fiddler might be useful for this purpose. In the Internet Options | Advanced, are you using HTTP 1.1? – Somantra Dec 2 '10 at 22:46
  • No, but that is a good suggestion. However, the problem is at authentication. I am pretty sure if you do not configure the wget params right, wget will just hang or immediately die with a 403 forbidden error. I need to see whats wrong before or during the authentication, so I am not sure wget will help. I know it is IE8 specific specifically because the problem cannot be recreated in Firefox 3.x, installed on all problematic machines. – songei2f Dec 12 '10 at 13:08

Not the answer you're looking for? Browse other questions tagged or ask your own question.