I'm installing SQL Server 2008 R2 using a DVD that says 32/64onto a Windows Server 2008 R2 server. I want to install the 64-bit version of SQL Server 2008 R2. I am installing SQL Server with the failover cluster feature enabled and configured. However, when I run the SQL Server 2008 R2 setup file I get the following error.

The version of this file is not compatible with the version of Windows you're running. Check your computer's system information to see whether you need an x86 (32-bit) or x64 (64-bit) version of the program, and then contact the software publisher.

When I look at the Event Viewer I see the following error:

The program or feature "\??\D:\setup.exe" cannot start or run due to incompatibity with 64-bit versions of Windows. Please contact the software vendor to ask if a 64-bit Windows compatible version is available.

The SQL Server 2008 R2 installer is 32/64 bit and of course Windows Server 2008 R2 is 64 bits. What could be preventing the installation from proceeding?

  • I can confirm that SQL 2008 R2 x64 works on W2008R2 x64, we've got that setup here. Have you tried re-installing Windows? Commented Oct 19, 2010 at 13:40
  • Nope, But I tested the installer on other machines and got the same error. When the machine is 32 bits it just opens a prompt and closes it in a second, when the machine is 64 bits it throws that error up Commented Oct 19, 2010 at 13:46
  • Check the ISO of the SQL Server installation and make sure there is a folder called x64. If there is, try running the setup file found in that folder. Commented Oct 19, 2010 at 14:41
  • There is. The folder is in there. Commented Oct 20, 2010 at 12:04

1 Answer 1


I managed to Work this around.

I found this pre req on installing SQL on Cluster.


under: Other Software Considerations

There's this pre reqs:

SQL Server Setup support files. You can install these files by running SqlSupport.msi located on your SQL Server 2008 R2 installation media.

I Located that file On:


That installed the setup on the machine. Then I ran the setup from the All Programs Menu and after that pointed the disk when asked.

I Noticed that after installing SQL the Setup begins to work normally. This must have happened by some weird pre-req, that the setup must have installed for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .