The operating system is Windows Server 2003 R2 x64 with all updates applied.

I have an external hard disk enclosure (one of these) with a 1 TB drive (garden-variety Seagate). When I right-click in Explorer and choose “Format…” the only option is exFAT. I really want NTFS.

  • If I do try to format as exFAT, I get a generic error message: “Windows was unable to complete the format.”
  • Other external drives give me a choice of NTFS or exFAT.
  • Problem occurs over both USB or Firewire.

Workaround: I was able to use diskmgmt.msc to format as NTFS.

But I am wondering:

  • Why wouldn’t Explorer offer NTFS as an option? Is this a red flag for problems?
  • If NTFS is not a formatting option in Explorer, should I do anything with the disk? Re-partition?

To me it sounds like a Windows bug. There are a few things that you can do one place but not others, and in my experience a few more of those crept in with 2008 R2. You may have found another one. The fact that an NTFS partition could be put on there at all, especially in diskmgmt, suggests that there is no problem with it. That MMC is as close to the One True Disk GUI for Windows as Windows gets, so that option not being available in the Exlorer Format menu is not a red flag for me.


System will choose the most suitable file system format for the USB drive to be formatted, but it usually lists all file system formats that can be used. have you tried the formatting thing on other operating system like Windows 7 or 8? Maybe the formatting will be done successfully by other systems. If you still get the eror message "Windows was unable to complete the format", then there must be something wrong with the external drive such as bad sectors. in that case, you should contact the tech support of the drive for help. anyway have a try and good luck.


Off the top of my head I'd suggest that you machine thinks your drive is flash memory based rather than magnetic, were there any device drivers available to install?

  • No. The enclosure came with some backup program but no drivers as far as I can tell. – Nate Oct 19 '10 at 20:23

The problem is probably that the Windows thinks the drive is removable. Since this is over USB or FireWire this is probably an external drive. You need to make the os believe that the drive is mounted as an internal drive. A possible reboot with the drive attached during the boot process might do the trick. Otherwise you might need to mess with the directory.

There is an issue with using ntfs with removable drives which could leave the drive unstable if the drive is disconnected without a proper dismount. So there is a risk using ntfs. This is why the remove hardware option is there.

More info at rshullic.wordpress.com

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.