I'm trying to install phusion passenger nginx module, but it fails

# passenger-install-nginx-module

* Curl development headers with SSL support... not found


yum install curl-devel

Setting up Install Process
Package curl-devel-7.15.5-9.el5.x86_64 already installed and latest version
Package curl-devel-7.15.5-9.el5.i386 already installed and latest version
Nothing to do

What else needs to be done?
I use: CentOS 5.2, Phusion Passenger version 3.0.0, nginx/0.8.53

# gcc -v
Using built-in specs.
Target: x86_64-redhat-linux
Configured with: ../configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --enable-shared --enable-t
hreads=posix --enable-checking=release --with-system-zlib --enable-__cxa_atexit --disable-libunwind-exceptions --enable-
libgcj-multifile --enable-languages=c,c++,objc,obj-c++,java,fortran,ada --enable-java-awt=gtk --disable-dssi --enable-pl
ugin --with-java-home=/usr/lib/jvm/java-1.4.2-gcj- --with-cpu=generic --host=x86_64-redhat-linux
Thread model: posix
gcc version 4.1.2 20080704 (Red Hat 4.1.2-48)
  • Does the curl-devel package install headers with SSL support? That would be one explanation of the error. Another might be that the package installed the libraries into a directory passenger-install-nginx-module isn't checking, e.g. /usr/local/lib rather than /usr/lib, but I don't rate that possibility very high. – pjmorse Oct 20 '10 at 16:04

yum install libcurl-devel


Install these:

yum install zlib-devel e2fsprogs-devel krb5-devel


Refer to code.google.com/p/phusion-passenger/issues/detail?id=554 for a discussion of this issue.

Particularly, Comment 4: code.google.com/p/phusion-passenger/issues/detail?id=554#c4

The installer is hiding useful error messages. I was getting the same error on CentOS 5.3 with curl and curl-devel 7.15.5 installed.

I solved this problem by installing:

zlib-devel e2fsprogs-devel krb5-devel


It is actually libcurl-dev instead of libcurl-devel.

  • > It is actually libcurl-dev instead of libcurl-devel. is that for Debian (Debian-like) systems? The poster is asking about CentOS – user62363 Dec 2 '10 at 19:41
  • At least on my system, CentOS 6, with the repos I have installed, it's libcurl-devel. Didn't fix my problem, but still... :) – rinogo Dec 4 '14 at 21:02

sudo apt-get install libcurl4-openssl-dev

  • 1
    This is a Cent OS related question and Cent OS uses yum as default, not apt-get. Also, this question has accepted answer from 2010, so this isn't adding any value at all. – Esa Jokinen Mar 21 '15 at 23:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.