Normally you can right-click an executable and select "Run As" and away you go, but it doesn't work for .msi files.

5 Answers 5


You shouldn't have to start MSI's with elevated privileges if you're already logged-on with an Administrator account. The Windows Installer service will elevate automatically (and prompt you w/ UAC, if your OS is configured to do so).

If you're not logged-on as an Administator, you'll want to do:

runas /user:<administrator username here> "msiexec /i <Path and Filename of MSI"

That will start an installation.

You could also just open an elevated command prompt, go to the directory where the MSI is sitting, and key in the MSI's name at the command prompt (with the .MSI extension). That will also start an installation.


Or use the GPO setting "Always Install with Elevated Privileges" in Admin Templates/Windows Components/Windows Installer.


Another option is to add a registry key in XP:

Edit the key


and set the value to:

Install &as...

Create the following key:


and set it to

msiexec /i "%1"

Then right-click the MSI and there you go. I wouldn't suggest this method unless this is something you do all the time though.


The registry hack, I created a tiny windows application to do it. Download a copy here - https://runasadminmsiexttink.codeplex.com and run the application to enable/disable Run as Administrator context menu option for .MSI files.


One of the main features of MSI is that users are to be able to run with temporary "elevated rights". This means that users can install MSI files advertised to them, and the MSI will have elevated rights (similar but not identical to admin rights) for the duration of the install.

This elevation is enabled either by group policy as stated above, or by a registry setting. Obviously go for the policy approach if you can.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .