We are trying to configure SSL for one of our domains hosted on a Red Hat server running Plesk.

Plesk version: 9.5.2
Apache: 2.2.3
Redhat: 2.6.18-194.el5

  1. We created a new SSL certificate entry under Settings > SSL Certificates.
  2. We generated a CSR.
  3. We purchased a RapidSSL certificate using that CSR.
  4. We installed the resulting Private key, certificate and CA certificate under the new SSL cert entry we had added to Settings > SSL Certificates.
  5. We went to Settings > IP Addresses and selected the IP that the domain is hosted on. The IP is exclusive to one domain.
  6. We set the SSL certificate to be the new cert we had just added and set the default domain to be the exclusive domain on that IP.

Now if we go to https://example.com, the certificate validates but it sends us to the default Plesk HTML page. Our regular http://example.com still loads fine.

  • We have tried setting up the certificate under the domain itself instead of under Settings > SSL certificates but have found that this breaks our regular HTTP site.

  • We have tried with our current settings going into the web hosting settings for example.com. There we tried turning on SSL support, but if we do that it defaults back to the self-signed certificate.

  • We have tried setting it to use a single directory for housing SSL and non-SSL content, but that setting doesn’t save if we don’t have SSL support turned on for the domain, and if we turn it on the we run into the self-signed cert problem.

So, we have managed to get the HTTPS validating the SSL certificate, but we can’t seem to get it to load any pages located in either our HTTP or HTTPS dirs: it always tries to load from the Plesk default dir when we are using HTTPS.

How do we set up Plesk to use either our HTTP or HTTPS dir for our HTTPS requests rather than defaulting to the Plesk default dir?

We started looking into the possibility of editing the httpd.include file for the domain and adding another vhost, something like:

<VirtualHost ourdomain.com:443>
SSLEngine On
SSLCertificateFile c:/Apache Group/Apache2/bin/mydomain.crt
SSLCertificateKeyFile c:/Apache Group/Apache2/bin/mydomain.key
DocumentRoot "path to document root"
<Directory />
Options FollowSymLinks
AllowOverride None
Order deny,allow
Deny from all
Satisfy all

However, we can only find the CA certificate location on the server and are unable to find the key file location.

Any help on how to set up Plesk to use either our HTTP or HTTPS dir for our HTTPS requests rather than defaulting to the Plesk default dir would be greatly appreciated.

  • when you find the answer please tell me, i am SO frustrated with the same issue....... same exact freaking thing. – user75474 Mar 23 '11 at 5:06
  • We spent weeks looking for the answer, and in the end we got a cert for another server just running apache on BSD with no control panel and had it up and running in minutes. We then use curl to send results back to the main server. – direct00 May 19 '11 at 2:52

Man, this one drove me crazy.

Parallels Knowledgebase Article 939: Wrong certificate is shown for my domain in the browser will work.

Be sure to make a copy (# cp ssl.conf ssl.conf.save) before you change anything.

You have to make sure to comment out the whole

<VirtualHost _default_:443>

section in its entirety, not just one line, or you will get an error when you reload ssl.conf.

The person in Plesk SSL Certificate (Default cert when SSL enabled, CORRECT cert when SSL is disabled) did not comment out the whole section, and therefore got the error.

You can stop / restart httpd (like it says). I advise just rebooting the whole server afterwards.

For my config in Plesk 9.5 I chose “SSL support” not “Use single directory...” so your visitors will not get a warning message regarding mixed secure and non-secure data.

Also, if you are working/testing this with multiple browsers, you need to clear the browser’s internet cache and restart, as many of the major browsers will store the previous failed HTTPS connection.


I've seen a problem like this in the past which has been caused because of the default mod_ssl configuration file from the httpd package (/etc/httpd/conf.d/ssl.conf) overriding the Plesk SSL installed in /var/www/vhosts/domain.tld/conf/httpd.include — if this file exists I'd suggest deleting everything in that file starting from the <VirtualHost *:443> line.

You'll definitely need to enable SSL support for the domain, and presumably you'll want the single-directory mode turned on.

Not the answer you're looking for? Browse other questions tagged or ask your own question.