8

I am unable to copy and paste between my desktop a remote desktop session even though Clipboard is enable under local resources in the Mstsc.exe

I'm on a Windows XP SP3 connected to Server 2003.

  • Can you copy and paste AT ALL, or does it stop working after 30 minutes or so? – Mark Henderson Oct 25 '10 at 6:52
6

When you run mstsc.exe (the client), go into options and go to the Local Resources tab. Ensure "Clipboard" is selected in the "Local devices and resources" group.

If you have a pre-defined .rpd file, right click to edit and get the options, then ensure you save the file to persist any updates.

Also check that clipboard integration is not disabled on the server. I'm not sure that a normal user can check this, but with suitable rights it is easy. On the server in Remote Desktop Session Host Configuration (or Terminal Services ... on older Windows versions) select properties for the connection and the Client Settings tab allows various client integration functions to be disabled (checking the checkbox disables the feature).

EDIT: Thanks to @Sergy for reminding me that clipboard integration can also be disabled on the server.

  • That sure is selected and Im not running it from a .rdp shortcut. – Jake Oct 25 '10 at 8:40
  • 3
    Clipboard redirection can be disabled in terminal server configuration (it will override user settings). – Sergey Oct 25 '10 at 9:47
  • @Sergey: good point, time to update the A. – Richard Oct 26 '10 at 8:40
  • @Sergey - How can I know (as user - not as admin) if Clipboard redirection is disabled ? – itsho Jun 10 '14 at 10:32
9

If copy paste is enabled both in the server and the remote desktop connection but still doesn't work, the following works for me (taken from here):

Do the following on the remote machine:

  1. Load up task manager (right click taskbar and select Task Manager)
  2. Go to the Processes Tab
  3. Select rdpclip.exe
  4. Click End Process
  5. Go to the Application Tab
  6. Click New Process
  7. Type rdpclip
  8. Click Ok
  • 1
    This is better than the accepted answer! – Mert Meral Jan 6 '17 at 7:58
  • This works like a charm!! – Arbaz Alam Sep 25 '17 at 6:10
1

I had similar issue. There was no change in any settings but this problem was faced by few users on my RDP server. What i did to fix the issue was I went to Start>Administrative Tools>Remote Desktop Services>Remote Desktop Services Manager Right clicked on the user with copy-paste issue and clicked reset. Logged in again with RDP and the copy-paste function was working again.

0

If you're using Remote Desktop Manager to manage a group of RDP connections, make sure that for the individual connection, the resources tab isn't overwritten by the "inherit from parent" checkbox.

0

If you happen to have Administrative credentials to the remote machine and it's accessible over the LAN, don't forget about the good ol \\hostname\C$ hidden share. You can use this to transfer files to/from the remote host.

  • The question was about copy/paste or clipboard sharing over Remote Desktop, not about file sharing. – music2myear May 15 '17 at 19:27
0

Restart RDP Clip Monitor process on both hosts. You can do this by following the below steps:

Steps:

  1. Open windows run command (Windows Key + R).

  2. Hit below command

Taskkill.exe /im rdpclip.exe

  1. Above command will kill RDP Clip Monitor process, and then you can restart the process again by running the following command:

rdpclip.exe

It should start the process again and the clipboard should start working again now.

0

You can also check:

GPO (local or domain):

Local Computer Policy - Computer Configuration - Policies - Administrative Templates - Windows Components - Terminal Services - Terminal Server - Device and Resource Redirection

Do not allow clipboard redirection

mstsc:

Remote Desktop Connection > Options > Select checkbox "Clipboard"

Extracted from:

https://www.sysadmit.com/2018/06/windows-copiar-pegar-escritorio-remoto-no-funciona.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.