I have a windows server 2008 machine, which I had sql server 2005 running on happily, then I needed to install 2008 R2 for another job. I was hoping to run them side by side. I configured 2008 to run as SERVERNAME\SQLSERVER08 and 2005 is on SERVERNAME. However now I cannot get 2005 to run... whenever I try to start the service it says:

Windows could not start the SQL Server (MSSQLSERVER) service on Local Computer. Error 1053: The service did not respond to the start or control request in a timely fashion.

Any ideas would be much appreciated!

More Info:

There are no log files in the log directory In Event Viewer there are is an error:

Faulting application sqlservr.exe, version 2005.90.4053.0, time stamp 0x4a1c88c7, faulting module kernel32.dll, version 6.0.6002.18005, time stamp 0x49e037dd, exception code 0xc06d007e, fault offset 0x0003fbae, process id 0x1404, application start time 0x01cb75001573c2cc

  • Anything named like SQLDump0001.txt (or .log) in C:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\LOG? – jl. Oct 26 '10 at 16:25
  • nope, nothing in log directory at all! – Mark Milford Oct 29 '10 at 13:09

Check the error log in Program Files\Microsoft SQL Server\MSSQL.#\MSSQL\Log to see what it's complaining about. There might also be some useful information in the event log.

  • thanks, have provided more information... none of it that i can seem to see a solution – Mark Milford Oct 26 '10 at 12:21

Ah I think I remember this now. Both 2005 and 2008R2 are trying to listen on the same ports, 2005 can't bind to that port since 2008R2 has it so it bombs out. Try changing the port configuration for either 2005 or 2008R2 and give it another shot. To do a quick verify, if you stop 2008R2 then 2005 should start right up and 2008R2 will give you errors.

  • tried stopping 2008r2 and 2005 still would not start :( – Mark Milford Oct 26 '10 at 13:31
  • Is the agent/browser service still running? – Dan Oct 26 '10 at 13:39
  • tried changing the port as well... nothing – Mark Milford Oct 29 '10 at 13:09
  • Try starting SQL from the command line to see if it gives you any more information as to what it was trying to do when it bombed out... msdn.microsoft.com/en-us/library/ms180965.aspx – Dan Nov 1 '10 at 13:28

I think the problem is with the port as Dan mention before me. Try change the default port of one of the instance (Either 2008 or 2005)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.