I have installed SQL Server 2005 but there is no server, I have reinstalled it about 5 times and the same problem never changes.

And here is the error message

Cannot connect to ..


A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server) (Microsoft SQL Server, Error: 2)

  • What do you mean by saying "there is no server"? How do you try to create new DataBase? – Serkan Hekimoglu Oct 26 '10 at 16:07
  • 3
    This is 4th almost identical question posted by you! Can you explain exactly what you want to do? You installed SQL Server and now you're trying to establish a connection, right? (1) What tool are you using? Management Studio? (2) Are you connecting from the same machine or a remote one? – Marek Grzenkowicz Oct 26 '10 at 16:12
  • 4
    And please do not post more questions regarding this issue; it doesn't help. If you want to add some piece of information, edit existing question. – Marek Grzenkowicz Oct 26 '10 at 16:16
  • You need to clarify your question - asking the same question over and over again without more information about your problem won't help.... e.g. what edition of SQL Server 2005 did you install - Express, or Developer, or what?? What do you mean by *there is no server.... how do you see that there's no server?? What tool are you using trying to connect to that SQL Server isntance?? – marc_s Oct 26 '10 at 16:18
  • possible duplicate of [Cannot Connect to the SQL Server , SQL 2005 and it doesnot want to connect to the server and there is no Server name ? ](stackoverflow.com/questions/4022136/…) – Mark Bannister Oct 26 '10 at 16:28

Sounds like it could be one of the following:

  1. You think you're installing the server, but what you've really done is install the management console client.
  2. You've installed the server, but the listener service is not running.
  3. You assume you have the correct information (e.g., URL, username, password) for connecting to the server, but you don't.
  4. You've got the server installed, the listener is running, and you have the right credentials to connect, but there's a firewall in between your client and the server that prevents you.

Start by trying to ping the server where you think the database is running from the client machine. If you can't ping, you can't connect.

If all this is happening on your local machine you've made a mess and should start again.

| improve this answer | |
  • 2
    Could be he just needs to look at the surface area configuration – Gaius Oct 26 '10 at 17:23
  • Maybe there is an Instance on top of your server. If so you have to connect to "servername\instancename". – Ice Nov 7 '10 at 22:04

The first thing you need to do is realize what you're working with. Full SQL or just the Express version.

  • If it is the full SQL -> start Management Studio
  • Does it run? Yes. If no, check that SQL services are all started in either Windows Services or SQL Configuration Manager.
  • If Management Studio starts, does it see the SQL instance? Yes -> Try connecting.
  • If it fails, then use the specific error code to look it up.
  • If you can't still connect to SMS -> Something is wrong with the services. Go back.

SQL express will be a bit more complicated to troubleshoot since there is no Management Studio installed.

As everybody mentioned, help us to help you. Clear information would make this a lot easier.

Also, just because you've reinstalled something 5 times doesn't mean things have to change. Windows' registry remembers settings so it could be that all 4 consequent installations are remembering settings from the first one. Solution: Reinstall or go through the registry and the system with a fine comb to remove any traces of your installation.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy