0

So I'm logged onto a remote desktop session as Administrator. The CPU usage is pegged at 50% with the csrss.exe process running under the Console session as the culprit.

I can't log off the Console user from the Task Manager and I can't restart using "shutdown /r /f"

Is there any way I can force the server to restart or kill the Console session? There is no one else logged on to the server right now and I don't have physical access to reset it. Explorer is barely responsive but the task manager and command line and working fine.

  • I had a similar problem once and can't recall a happy ending. I think I used process explorer to try and kill every possible process and thing i could find on the console. Eventually I froze the box and had to get the data center tech to restart the box :-( good luck. And it hasn't happened since – jqa Oct 30 '10 at 1:19
1

Have you tried taskkill.exe /pid <pid> /f for the CSRSS.EXE process?

  • Thanks for the suggestion but nothing appears to happen after issuing the command. – Lucifer Sam Oct 26 '10 at 22:44
  • Does the server have any "out of band" management interface, like HP iLO or Dell Drac? – Simon Catlin Oct 27 '10 at 20:38
-1

If you have RPC access to the machine (e.g. not firewalled), you can run Shutdown.exe remotely.

shutdown \\remotehost /r

(Also, for reasons I've never understood, nltest.exe also has a remote shutdown option built into it, but not a reboot command.)

  • Questions mentions shutdown /r /f doesn't work. – Chris S Dec 13 '10 at 18:57
  • [shutdown /r /f] specified by OP is the syntax as issued from a local cmd session. [shutdown \\remotehost] is issued from a remote host, and uses RPC to connect to the machine in question over the network, potentially circumventing whatever is hanging the console session. CPU pegged at 50% tells me one of two cores is busy with misbehaving software, leaving one free; OP still may be able to administer system from someplace other than logged into a desktop session. – AndyN Dec 14 '10 at 18:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.