We're running PHP 5.2.5 on an IIS 7 Server and we're having problems making PHP errors visible... At the moment whenever we have a PHP error the server sends back a 500 error with the message "The page cannot be displayed because an internal server error has occurred."

This might be a good setting for production websites but it's rather annoying on a development server... ;-)

I have tried configuring php.ini to display errors to the screen as well as log them to a specific folder but it seems that the Server catches all errors before and prevents and handling by PHP...

Does someone know what we have to do to make IIS display PHP errors on screen? Any links, tipps or tutorials on the subject would be appreciated!

  • First, ensure that you have these: log_errors=1, error_reporting=-1, log_errors_max_len=0. – Pacerier Aug 27 '15 at 17:05
  • ini_set("display_errors", "on"); add these lines in php file. – ELITE Feb 28 '16 at 6:20
up vote 34 down vote accepted

Just to double check, do you have logging set to error_reporting = E_ALL, and display_errors = On in your php.ini? Usually this is enough to display these errors in IIS 7.

Next, take a look at your IIS settings, as it may be set to only show error messages locally. In the IIS 7 configuration editor this is under system.webServer->httpErrors. You will need to change errorMode to Detailed from DetailedLocalOnly. Obviously this now means anyone browsing your site will be able to see the error.

enter image description here

enter image description here

Alternatively, if you want to keep them local you can use Remote Desktop to log in to the server and run the app from there, if you can.

  • 1
    Yes I checked and that's all configured properly. – Ben Jun 4 '09 at 10:29
  • Added some more troubleshooting info – Sam Cogan Jun 4 '09 at 10:37
  • 1
    Changing the errorMode to "Detailed" from "DetailedLocalOnly" did the trick. Thanks! – Ben Jun 4 '09 at 12:37
  • 1
    I had to remove the collection of HTTP errors under system.webServer as well. Didn't work with PHP until I did. – user121207 May 16 '12 at 3:36
  • 1
    Please highlight that system.webServer with my blood and add note: "Yes, there is combo". – DiGi May 22 '12 at 12:39

Just wanted to add, that "existingResponse" should be set to "PassThrough". I didn't get any real error messages without that additional setting.

  • 1
    Where is located this setting? – Eugene Mala Jun 25 at 18:02

You can do this easily using the IIS Manager GUI. Select your Site and double-click Error Pages. Then hit 'Edit Feature Settings...' and select the 'detailed errors' option instead of the default 'detail errors for local requests and custom error pages for remote requests'. Voilà, simple as that!

  • Where can the logs and errors be shown then? – JukEboX Nov 3 '16 at 13:24

I had to go into the settings on the webserver into php configuration and there is a setting in there for error reporting and is set to production by default. Had to change it to development even after changing the php.ini and the suggestion here. I am using iis 7.5 on 2008 R2.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.