1

I installed VMWare Server on a 64 bit XP machine.

After creating a new virtual machine (for XP 64 bit guest OS) and adding a CD pointing to XP64 setup ISO, VMWare doesn't let me run the virtual machine:

Attempting to load an x64 operating system, however this CPU is not compatible with x64 mode. Please install a 32-bit X86 operating system.

What gives? (My host is definitely a 64 bit machine)

13

You require Intel-VT or AMD-V support for your processor in order to run 64-bit Guests.

If your processor supports it, it can usually be enabled through the BIOS. If you can't find the option there, chances are it may not be available.

Some more reading here

3

That will be it, but also after you switch the bios setting you will need to power down the whole PC, I also pulled power to ensure there was nothing going to the motherboard.

The setting is "locked" into whatever position its in a long as power is applied regardless of setting.

  • +1. This trips up a lot of people apparently. I used to assume a reboot (which you always do with changing BIOS settings) was the same as a full power off/on cycle as far as the BIOS settings were concerned. I've recently learned otherwise. – kbyrd Jun 17 '09 at 12:47
  • A related tip - to ensure that the capacitors in the PSU are completely drained and there is no power whatsoever going to the motherboard, hit the power switch once you've disconnected from the mains. This will cause the motherboard to use whatever residual power is left in the caps. – tomfanning Aug 12 '09 at 10:49
2

Figured it out.

There's a BIOS switch that needs to be turned on (turned of by default) on Intel machines: VT Support.

Once I enabled it everything works.

More info here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.