I fighting with the WOL settings of my Ubuntu box at the moment. The idea is to have an HTTP/SVN server to sleep while it's unused and wake up when it's accessed. So far, wake-on-LAN works and is activated on startup:

Settings for eth1:
        Supported ports: [ TP ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
        Supports auto-negotiation: Yes
        Advertised link modes:  Not reported
        Advertised pause frame use: No
        Advertised auto-negotiation: Yes
        Speed: 1000Mb/s
        Duplex: Full
        Port: Twisted Pair
        PHYAD: 0
        Transceiver: internal
        Auto-negotiation: on
        MDI-X: Unknown
        Supports Wake-on: pg
        Wake-on: pg
        Current message level: 0x0000003f (63)
        Link detected: yes

As you can see, I also set the wol p flag ('wake on physical activity'). My assumption was that I could convince the device to wake up not only on magic packets, but on any network access. This, however, seems to be wrong.

What does this flag mean then, and: (How) can I misuse this for my evil plans?

-- Markus (cross-post)


WOL typically requires a "magic packet" to actually "wake-up" a WOL system when it is "sleeping" or in an "off" state. The "magic packet" is a specific "message" instead of just any casual network activity.

Some NICs have advanced power management features where it can "wake" a system based on network activity, but like WOL not all models necessarily have this capability.

  • So far so good, but what exactly is that "physical activity" mentioned by ethtool? – sunside Nov 2 '10 at 1:50
  • Which line is referring to "physical activity" on your output? – user48838 Nov 2 '10 at 6:09
  • Supports Wake-on: pg and Wake-on: pg. According to the ethtool man pages, p stands for physical activity. – sunside Nov 2 '10 at 13:35
  • "NICs have advanced power management features" - it comes down to what you NIC driver actually supports. – user48838 Nov 3 '10 at 1:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.