I recently upgraded our Exchange 2010 from rollup 4 to Service Pack 1, rollup 1.

After the upgrade users can no longer open public folders using Outlook. Instead, they see this error:

The set of folders cannot be opened. Microsoft Exchange is not available . Either there are network problems or the Exchange server is down for maintenance. (/o=DOMAIN/ou=Exchange Administrative Group (....)/cn=Configuration/cn=Servers/cn=MAILSERVER1)

Public folders can still be opened using OWA. We are using Outlook 2010 on the desktop. Any suggestions?

I tried using the new Public Folders Management tool in Exchange Management Console. When I click on a public folder and try to change the settings on it, I get this error:

Microsoft Exchange Error

Action 'Update Content' could not be performed on object '_Blah:SampleFolder'.

_Blah:SampleFolder Failed Error: Cannot start content replication against public folder '_Blah:SampleFolder' on public folder database 'Public Folder Database'.

MapiExceptionNoReplicaAvailable: StartContentReplication failed. (hr=0x80004005, ec=1129) Diagnostic context: Lid: 1494 ---- Remote Context Beg ---- Lid: 18084 StoreEc: 0xFFFFF9BF Lid: 33819 StoreEc: 0x469
Lid: 27225 StoreEc: 0x469
Lid: 1750 ---- Remote Context End ---- Lid: 26322 StoreEc: 0x469


We've also (unrelated?) had two blue screens on the Hyper-V server hosting our Exchange VMs. Something I haven't seen in quite a long time.

Here is our architecture:

CAS server (hosts OWA also)

MailServer1: DB1, DB2, Public Folders

MailServer2 DB3 (also has CAS server role)

I saw this recent question: Can't access public folders after upgrade to Exchange 2010

I also have a Dell server! However, following these instructions didn't resolve the issue on my machine, and I was going from Exchange 2010 RTM to SP1.


Okay, sorry to dismiss the earlier Server Fault message--it led me on the right track, at least. I called Dell support and had them walk me through disabling the performance features on the NIC, which resolved the issue. I think the key was disabling global chimney and receive side scaling, as I had tried most of the other steps as per the other Server Fault question posted. Of course none of these settings should cause problems, so maybe it's going to vary from server to server.

I also upgraded the driver version for the NIC, applied a BIOS patch and the latest Windows optional update rollup for Hyper-V issues, including a blue screen issue that we had experienced twice in the last week: KB2264080.

Here's the Dell support script I followed:

In a command prompt:

a. netsh int tcp set global chimney=disabled

b. netsh interface tcp set global rss=disabled

b. On each NIC inside the Broadcom Advanced Control Suite (BACS)

i. Disable IPv4 Checksum Offload

ii. Disable IPv4 Large Send Offload (LSO)

iii. Disable Receive Side Scaling (RSS)

. Uncheck the TCP Offload Engine (TOE) checkbox

v. Click Apply

Intel Configuration

a. Open Device Manager

b. On each Intel NIC in Device Manager, disable the following:

c. NOTE: Not every option is available or exist on the Advanced Tab.

i. Offload Receive IP Checksum

ii. Offload Receive TCP Checksum

iii. Offload TCP Segmentation

iv. Offload Transmit IP Checksum

v. Offload Transmit TCP Checksum

vi. IPV4 Checksum Offload

vii. Large Send Offload v2 (IPV4)

viii. Large Send Offload v2 (IPV6)

ix. Receive-Side Scaling

x. TCP Checksum Offload (IPV4)

xi. TCP Checksum Offload (IPV6)

In Windows Server 2008

                                                                                 1.      Start à Run à CMD 

                                                                                 2.      netsh interface tcp set global rss=disabled 

a. netsh int tcp set global autotuninglevel=disable


Public folders aren't DAG members and clients can't find replicas if the primary server is unavailable to hand out referrals. Is your primary public folder database mounted?

  • Just tried manually mounting the database. No messages. Checked event log, says the database was successfully mounted. Still getting the same error in Outlook 2010. I'm not sure what you mean about the primary server being unavailable to hand out referrals--can you explain? I have three Exchange Servers, all of them are "available" in the sense that they are turned on, are responding to pings, and seem to be correctly functioning, with the exception of the public folders functionality. – Quinten Nov 1 '10 at 20:37
  • Also, note that I am still able to access the public folders when I use OWA. It's not a complete failure. OWA is running on my CAS server, separate from the machine that hosts the public folders database. However, they are all on one hyper-v host. – Quinten Nov 1 '10 at 20:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.